Tricopter cannot climb above 1m

Hey guys

Having a strange issue on my wicked tricopter setup. It’s not using GPS but instead it has px4flow. I have followed all guidelines on killing the GPS system.

First problem is that I cannot even switch to Loiter mid-flight. I take off in Stab, I can go into althold but when trying to go into Loiter, it just says Mode change failed. Allright.

On the ground though I can switch into Loiter, no problem. And I can take off, position and althold is crazy good. However, the copter climbs only to about 1m and stops there. I push full throttle, nothing happens. I can only descend and hover. To climb, I have to go back into Stab mode, but then I can’t go back into Loiter. I’m about ready to wash my hands off this weirdness.

Seems there’s someone else having a similar issue but his wouldn’t go above 30m. Checked the thread, doesn’t relate to my problem. Any assistance will be greatly appreciated. I can’t send nudes, but I’ll happily send photos of the tricopter <3

A flight log would more helpful than nudes.
Have you checked the height parameters for the px4flow?
If you are under 1m can you switch to Loiter mid flight?

Thank you very much, I’m trying to download the flight log but it’s going very slowly.

I haven’t tried switching into loiter mid flight below 1m. I’m not sure where the height parameters are, I scoured the full parameter list one by one, haven’t found a single limitation where it shouldn’t go above 1m. This also happens in Althold. In example, I take off in Stab, climb to 5m and switch into Althold. No more climbing. It sits quite happily at 5m, I can descend too but when pushing the throttle to go up the tricopter just gives me a middle finger.

What rangefinder are you using?

Well, the PX4Flow module is made by Holybro and the rangefinder is a Maxibotix sonar. According to the specs, it has very good resolution and indeed it does work good when it works.

Sorry for the double post. Here’s a recent flight log where I tried to change flight modes mid-flight but I believe it should contain data where I took off in Loiter and tried to climb above 1m but failed.