Trex 500 with flybar and external gyro - ESC signal problem

I am trying to set up my classic trex fiberglass heli to get extra options stabilize and loiter mode. It is very useful when mosquito attack or some unexpected visitors come when You are in the air :slight_smile:

My hardware:
Matek f405-std FC
Futaba T8J with oryginal futaba s-bus receiver

So in my setup on the Futaba radio channels are as follows:
1 - roll
2 - pitch
3 - engine
4 - yaw, tail control
5 - gyro sensitivity - this one is connected directly omitting FC
6 - collective pitch
7 - unused for now
8 - arming

so my parameters are:


According to the manual with this settings RSC shoud take engine value from engine_interlock which is set to channel 3 and passhtru to ESC. Unfortunately my heli doesn’t turn engine on. When I set RCIN3 as function for engine control then it works, but I know it is not correct way for auto modes. FC is arming when I press switch and no errors are shown.

It is also a bit confusing for me, that arducopter seams to expect to have constant rpm on rotor, while in my manual setup my rpm is controlled by channel 3 according to flight mode: normal, idle1, idle2 and throttle stick position. I would like to leave it this way, but ardu manual says that for automatic altitude hold RSC_MODE cannot be set to passthru. It can be set to follow collective pitch, but this wont do the job as in idle 1 for the same collective pitch I have different rpm than in idle2.
My goal is to preserve acro capability of my heli when it was fully manual (without FC) and to add loiter or stabilize option as an extra feature. Nothing more :slight_smile:

Can anyone help with engine throttle issue?
I have seen movies about configuration and so on, but can’t figure it out in my case.

My config is:
2021-06-27-parametryTrex500.param (20.2 KB)

Does anyone has clue why ESC signal is not passed from engine_interlock channel?

Post in the Traditional Heli thread.

Thanks for a tip. I missed this category. :slight_smile:

@K4cus so are you using an ESC governor or a throttle curve?

I am using H_RSC_MODE,1 which should take engine_interlock channel value. Heli is electric with stock align ESC. There is no governor in this ESC. I have throttle curve programed in my radio and it is visible to FC on channel 3.

Ok. Thanks for the info. That was what I was looking for.

So even though you are using RSC passthrough mode, the motor will not be allowed to start until the interlock channel (rc channel 3) exceeds 1200 pwm. At that point, the output to the HeliRSC servo will ramp up to the current RC channel 3 value in 1 second. Then as long as the RC channel 3 value stays above 1200 then it will be passed through to the heliRSC servo output.

Yes, that is expected behavior however I can put Throttle stick fully up and nothing happens. I have wifi telemetry on and there is no errors shown, also arming with stick works as expected and heli is armed. That is why I asked on this forum. I am missing something.

Post a link to a log where you arm and then raise the throttle. Set the parameter LOG_DISARMED to 1 so I can see everything before and after you arm

It should be this one:

1 01.01.1980 01-00-00.bin (628 KB) 2 01.01.1980 01-00-00.bin (404 KB)

I am not sure if i did it right. I armed heli and put throtle to max. Then lowered and disarmed. Second file i think is correct.

The second file was fine. It showed me what I wanted to see. So I am puzzled by the behavior you are seeing. In the log, you can look at RCOUT.CH6 to see what is being sent to the ESC on that channel. It is not moving as it should be for the settings you are using. This all works fine in my simulation for the RC and SERVO set up that you are using. This could be board specific. However there is one parameter that was set improperly. You have ESC_CALIBRATION set to 3. Not sure if this was set intentionally but it should be set to zero. Please set it to zero and try arming and starting the motor. I’m hoping this is the issue.

Thanks for Your tip. I have changed ESC_CALIBRATION to 0. I think calibration failed some time ago and I didn’t notice that.

Unfortunately throttle passthrough didn’t work.

Now I set RSC_MODE = 2 and engine is spinning, but I have constant 70% rpm. Better that than nothing.

What I would like to achieve is:

Throttle passthrough if I am flying in stabilize or acro.

Throttle at fixed speed in altitude hold or loiter mode.

Is it possible? I was thinking (if I can get passthrough working) to set proper mixer in my radio on throttle (3rd) channel, so when i switch to loiter then mixer in my radio will automatically switch throttle to 70%.

@K4cus Ok, I figured out why I got it to work and it didn’t work for you. I used the simulation tool in mission planner. This uses the latest master version of software. I never thought that this was broken in previous versions of firmware. I had originally put in this change to have motor interlock work on other channels besides channel 8 and had it working or at least I thought it worked fine. Yours is a bit unusual for me as you use channel 3 for the motor interlock but makes sense with how you want to implement your set up.

So, this currently doesn’t work properly in 4.0.7. However It works in 4.1 which should be going stable soon (hopefully in the next month). Sorry for not finding this sooner.

Ok, thank You for your help. I will upgrade when it will be in stable branch. For now I was able to lift off and it has appeared that I have significant mechanical vibrations, so I need to fix it before continuing. I am very happy that arducopter works with classic heli, as this is the only software that supports all heli configurations :slight_smile:

In Futaba and older radios channel numbers are fixed by the manufacturer, so it is required to be able to remap channels on FC side for users like me :slight_smile:
I have seen these new radios with telemetry and stuff, but I won’t upgrade as long as my both Futaba radios (T8J and 9CHP super with multiprotocols module) are working. Futaba hardware is solid and I like it.
Anyway thank you for your time. Topic solved!

Best Regards,

If You are in Wrocław, Poland let me know, cold beer is waiting for You :slight_smile: :laughing:

1 Like