Trex 450 Tail Rotor Tuning

Well, that’s what the compass offsets are supposed to do is calibrate for nearby interference. They can get 'em to work in airplanes and cars with massive amounts of nearby EMI by calibrating the offset.

Yeah, well, the EMI was strong/variable enough that it would throw off my calibration, when it was mounted on the rear deck of the heli. You can enable the EKF compass variance value in the mission planner HUD and I could see it freaking out as I moved the heli around. This become much more stable after I put it back on the boom.
This also corresponds with what I saw in the field.
It’s annoying as I don’t trust it and it’ll take a handful of trouble free flights for me to do so.

Interesting. I’ve put the GPS/compass in that location on several heli’s and haven’t had an issue with it. You haven’t noticed any quivering servos, like one that’s got a noisy, scratchy pot starting to go on vacation?

So the heli will now hover hands off in stabilize. So that’s good…but I cannot get rid of this compass issue.
2 things I learned today:
-When I arm the safety switch, the variance freaks out. (to varying degree)
-When I, by hand, rotate the blades, (without the motor turning), the variance freaks out. (static?)

I can clearly see it changing as I move the servos around.
I’ve been putting it off, but I’ll need to make that cat5 cable for the GPS unit.
I’ll also try taking the drive belt off and see if I still get same level of variance without it.

This worked perfectly fine in my first setup, where the Pixhawk was mounted underneath the heli and the wiring was much more direct…but it isn’t really that practical a place for it. (And I want to make it work in it’s current position).

I doubt it’s static turning the rotor that slow. I would unplug the servos one at a time to eliminate the possibility of having a bad pot in a servo. Also try reverting to the old firmware and see if magically fixes it. If you don’t have any archived older firmware, PM me. I got several builds.

Well, the problem carried over when I upgraded to 3.5 (and swapped Pixhawk unit).
Will try the servo trick. Really don’t want to invest in new servos for this one, as I’m already eyeing larger helis.

Well, try the servo trick. It’s probably best to track down the source of the interference and fix it. If it’s a bad pot in a servo, you can take it apart and clean the pot’s wiper with WD-40. Done it many times on different servos. When the pot’s wiper gets dirty they usually start to groan a lot and even chatter sometimes. You’ll find the potentiometer right under the servo’s output shaft, usually engaged with a flat tang. It sends the servo’s controller the position information of the servo output shaft.

A scratchy or dirty pot can cause that issue. The input to the servo’s controller wants one position, the pot is telling the controller it doesn’t really know where the shaft is for sure, so it draws a lot of power keeping the servo’s motor “hunting” back and forth and that’s what makes it groan or chatter - and produce an excessively large magnetic field around it.

You’re right. It was the tail servo (Futaba BLS257). The reason I didn’t notice it on my first configuration, was that the GPS was a lot further down the boom. After I moved the Pixhawk, I had to move it further up and then in my final attempt, right next to the servo :weary:. Of course, this would only show up when the heli was armed and the reason it reacted when I rotated the blades, was because it was in stabilized mode and the servos moved…
Made a new shielded cable tonight appears to have fixed it?. Needs more testing, but will be out the next 2 weekends…

I don’t know if it did. Any cable with a shield has to have the shield connected to the reference ground for the system and the shield is more to protect the center conductors from common mode interference than to prevent RFI or EMI radiation from the cable. I didn’t look up the BLS257 to see if it’s a brushless servo but it probably is. Which means you have a little inverter on the circuit board in the servo that produces the square sine AC power to drive the brushless motor in it. And you have a potentiometer that sends the servo controller the position of the servo output shaft.

Excessive “noise” can come from either the pot or the inverter if it has a failed cap on the driver. There is some magnetic field around those servos, created by the mag field around stator in the brushless motor. But it is very small and weak and should not really affect the compass much even if the compass is right by it - at least nothing that a compass cal with the servos operating can’t adjust for.

It is likely that servo has a problem, especially if it seems “jumpy” or the tail is excessively “twitchy”, I’m guessing a dirty pot.

Well, I was getting zero variation in the EKF Compass Variation value, which would always move a little before (servo on or off). It was late when I finished, so only did a brief test, but will need to re-calibrate and test some more.
Meanwhile I’ll start looking for a new tail servo. Any recommendation for a 500 size servo that doesn’t break the bank?:slight_smile:

I’ve actually had pretty good luck with the Hitec servos for less money than Fubata’s, B-K’s, etc… I’ve flown them on both helicopters and TriCopters without issues.

So, got out again, old servo, new cable/GPS position and had seemingly no compass issues. A couple of very short spikes., but on wandering compass headings like before.
However: It really struggled to maintain the set altitude. This is not an issue I’ve had before. I noticed that you cover your pixhawks in a foam material?

I raised the altitude, ran a figure-8 mission and it was glorious. Tracking perfectly, (auto)-landed as straight as you’d want.
Decided it was stable enough that I could have a camera in one hand.
It was clearly not reaching the altitude it was supposed to and then it got confused, stopped and I dropped the camera and first switched it to loiter, sorta stabilized and then switched it to stabilize.
Logs show an EKF error and a high velocity spike. Vibes seem ok.
EKF compass variations looked good, so I launched it again and ran the mission again. Apart from then again being at the wrong altitude, it flew it nicely, although wind buffed it around again during the landing.
(I’ll add what video I got later)

Yes, vibrations look fine. When the EKF blew up on you it looks like it thought the heli was doing 50 mph and it got tossed around a little bit at 30 degrees of pitch and 20 degrees of roll (or so the EKF thought). It “switched lanes” on the EKF a couple times. reset the yaw a couple times - it basically got totally confused. At least you had some air under the heli. I had it happen this morning with a 700 and crashed that one. Didn’t have enough air under it and it happened too close to the ground.

I still haven’t figured out what caused my crash. But I do know this EKF “lane switching” is bad design for helicopters.

Yes, I put some foam covering over the Pixhawk. It seems to help damp gear train noise vibration, and protects the Pixhawk from flying grass and dirt when the EKF blows up and causes it to dig the rotor tips into the earth :joy:

I think your compass issues might be related to the firmware too. I’ve already had that problem as well.

Handheld Runcam2, so not the greatest camera for filming this kind. The blow-out looked way worse in real life!

Yeah, every one I’ve had in flight has been recoverable. It’s only close to the ground where it loses attitude solution that it’s been really bad. I’ve not seen it (yet) where the EKF blows and doesn’t sort of recover after a few seconds. But it can definitely make your flight interesting. I wish ArduCopter had a different attitude controller design where it maybe uses the EKF to keep the gyro drift calibrated, but doesn’t actually depend on it for the attitude solution. And if it goes haywire revert to the gyros and fly using good old dead reckoning until it straightens itself out.


I have been flying the Trex 450 with a new tail rotor. The tail appears quite good but the servo is moving back and forward really fast. I am using the suggested setting you made at the start of this post. I have tried adjusting the P and D down but it makes no difference.


David Ardis

David, first try setting the FILT param down to 10 or even 6 and see if that stops the tail servo ocillation. If it doesn’t, set the P, I and D values to zero, set the VFF to .15 and see if that stops it. If it’s still doing it then there is a binding problem in the linkage, a problem with the servo itself, or interference to the servo (like the MavLink radio). If it stops oscillation with the VFF set to .15 and everything else zero, then it’s a problem with the PID loop being too aggressive.

Chris did a few tests indoor this evening and with FILT param down to 6 the oscillation almost disappears. When you rotate the heli the yaw will give 2 or 3 small oscillations but after that its rock solid you can see the servo working but my feeling it quite normal. I have tried reducing the D gain from 0.007 down but at some point the tails starts to whip. Wondering if i should change anything else.

I’m sorry David, I didn’t catch this one when it came thru.

If the tail starts to whip back and forth radically, it’s a sign of the damping being to “soft”, i.e. it needs more P or D gain. If it oscillates rapidly that’s a sign that it’s over-damped (too much P or D gain.

Some heli’s and servos seem to like a little VFF on the tail. They’re not all the same, so it’s hard to make a recommendation. But try bumping the VFF maybe .02 or .03 more from what it is and soften the P or D by a notch and see if it gets rid of those 2 or 3 small oscillations.

A lot of tail servos are .06 second full sweep and they are so fast they don’t play nice with the PID loop. That’s where using a small amount of VFF might help.


No problem wednesday is our indoor flying night and it a good opportunity to sort the tail problems as the weather is rubbish

The Tail is sorted with the settings below

ATC_RAT_YAW_D , 0.006
ATC_RAT_YAW_I , 0.27
ATC_RAT_YAW_P , 0.25

Not super sharp but what I would call nice.
What i did notice is a small vibration which i will investigate.

I will be very interesting to get it outside in some wind.

Might be time for the flybarless head.

Thanks for your help

David Ardis