Traxxas rover moves, but steering doesn't work

I have a Traxxas rover and connected a Cube Orange running ArduRover 4.1.3 to it. I configured ArduPilot to GroundSteering on channel 1 and Throttle on channel 3. The servo output tab in MissionPlanner shows that there are output signals. However, the rover only drives forward and backward, but the steering servo doesn’t work.
I checked the power supply, and the servo has 5V. I also connected the old Traxxas controller again, and the ervo moves again, so it gets power and is also functioning.
What did I wrong? Do I have to configure the channel 1 differently to channel 3? The docs don’t mention any special configuration.

Check if you have the servo really plugged into “main out 1” and not “aux 6”. Been there, done that…

Thanks for the response. I have checked that. I also tried another channel for the steering servo, but also without success.

I measured the voltage output on channel 1. When the stick is centered, the output is 0.25V, when right it is 0.315V and left is 0.183V. When I remember correctly, the center position should result in 5V!?

Do you have a common ground between the signal and servo power?

You are incorrect about measured analog voltage of a PWM output - it will generally be very low. The fact that it varies with stick position is a good sign.

The ESC is plugged into the Cube to get it’s speed signal. With this connection, it powers the Cube’s main out + and - connectors. The steering servo is connected to those + and - connectors as well as it’s own signal pin.
The ESC also provides an external 9V connector. I added a stepdown converter to it to have the cube connected to 5V. I’m not sure whether ground is routed through the stepdown converter or not.
After your question, I also tried to connect receiver and cube immediately to the 9V connector. However, in this case it seems that the receiver and the Cube can’t establish an connection. The Here receiver LED turns green, but the Cube doesn’t “activate” the ESC and also the remote controller doesn’t receive telemetry. I don’t understand why, but it seems that without the stepdown converter, the setup won’t work. But if this stepdown converter prevents the steering servo from working…?

You almost certainly have a wiring problem, but your description is extremely confusing.

The Cube needs 5VDC on at least one of its power inputs.

Your servo probably requires more than 5VDC to run properly. It sounds like it needs 9VDC, but you should refer to Traxxas documentation for that info.

The + servo rail on the Cube is isolated from its power source, meaning that you can supply high current servo power on that rail at any voltage required.

Usually, you’ll want to tie the ground pins of the servo rail to the ground of the servo power supply to ensure a common ground between signal and power.

Under NO circumstance should you apply more than 5.3 volts to the Cube’s POWER1 or POWER2 ports.

I think Traxxis servo’s are rated at 6-7.4V

Hmm, sorry for the confusing answer. I’ll try to clarify this a little:

  1. The ESC has a three wire connector which is conected to the cube’s channel 3. This connection gives the ESC the PWM information from the Cube. And it also powers the servo rail with with 5.9V
  2. The ESC has a two wire connector that provides 9V. Those 9V go into a stepdown converter that outputs 5V.
    2.1. The Herelink receiver is connected to the 5V output from the stepdown converter.
    2.2. The Cube’s power 1 is connected to the 5V output as well.
  3. The steering servo is connected to the Cube’s channel 1 and is powered from the servo rail.
  4. Between the Herelink receiver and the Cube, there are two connections:
    4.1. Herelink S.bus to Cube RC IN
    4.2. Herelink UART to Cube Telem1

That wiring sounds correct, assuming that the 5.9V ESC/BEC output is capable of powering the steering servo.

Are you sure you have the signal wire correctly identified on the steering servo?

I guess so. There is a red one, a black one and a white one. They are all three connected to a single connector that also has a small notch to prevent it from being connected the other way round. With this connector, the red one is on +, the black one on - and the white is on signal.

And those 5.9V should be enough for the servo. I mean, it is it working with the original contrul unit, where the same ESC powers the servo rail as well. That lead me to the idea that the cube’s output is somehow “incorrect”.

the servo might not work with 3.3v servo signals. what servo is it specifically you are using?

I just tried the original contrul unit. There the servo is also powered with 5.9V.

That’s a very good point! I have not yet encountered that situation with a good number of servo brands, but it’s entirely possible.

GeoMuir is referring to the logic level of the signal - the Cube uses 0VDC for a logical 0 and 3.3VDC for a logical 1, where your servo might be expecting 5VDC on the signal line.

You could use a level shifter if that’s the case…but it’d be a lot easier to replace the servo with a compatible one.

What is the model number of the servo you’re using right now?

1 Like

Have you armed the safety switch?

I have heard about it with some exotic escs with high value protection resistors on the signal wire that won’t work with a 3.3v signal. if its an old servo its possible that it expects 5v signals, modern stuff I would expect to be designed to work with 3.3v as almost every micro controller runs at that voltage now.

It’s a Traxxas 2075X.

1 Like

thats a new servo i would expect that to work ok

1 Like

I had a Traxxis servo on a Rover, I think the Cube PWM level should work.


The safety switch is deactivated, and the main motor is running. I can also measure different voltage outputs depending on the stick position