Servers by jDrones

Traxxas ESC: Manual Mode, Delay in braking of 1 second... why?

I have a Traxxas ESC (Unlimited Desert Racer). When I use it out of the box with the stock transmitter, going from throttle forward to full reverse, the active braking works immediately. Now, when I insert the Pixhawk 2.1 with Ardupilot Rover (latest stable), forward throttle reacts immediately, but when I go to brake, there is about a 1 second delay before the active braking kicks in.

What is the source of this delay? Can it be tuned out, or is there a code change needed? I am trying to use this eventually in Auto mode (somehow) to send a STOP command to the Rover in MAVlink, but if it doesn’t work manually, I assume it won’t work in Auto.

Thanks for any guidance (no pun intended)!

Derek

Anyone have any inputs here?

Ren,

It’s best to turn off the active braking in the ESC and instead configure it so that it simply tries to reverse the motor. It’s mentioned quickly on the wiki here.

My view is the active braking in some ESCs is convenient to human pilots but for the AP speed controller it really isn’t necessary, in fact, it gets in the way because we have to add special handling for it.

Thanks for the response! There is no way to turn off braking for Traxxas:
https://traxxas.com/support/Programming-Your-Traxxas-Electronic-Speed-Control

All three modes use braking… but that is ok. Really, all it means is that I go Reverse while it is moving forward to activate active braking. I don’t see a need to disable braking, I am curious why if I have a controller and am going full throttle forward, that when I go full reverse, there is a 1 second delay before the car tries to stop. What is the cause for the delay? The delay causes issues with our Collision Avoidance work.

Secondary question - we are sending MAVlink commands to go to Waypoint. How can I send a MAVlink command equivalent to Full Reverse that would trigger the ESC to stop the car?

Thanks for supporting a ROVER, unlike some other autopilots…

Ren,

The delay is probably caused by the MOT_SLEWRATE parameter. If that’s set to zero I think the delay will go away.

Re a mavlink command to stop the vehicle… we don’t have a command which specifies full reverse but in any case, commands are normally at a higher level than that. So for example “go there”, “set speed to this”… etc… so it makes sense to have a “stop” command but then it should really be up to the autopilot how it does that. And a properly working speed controller should handle that without too much trouble. the SET_ATTITUDE_TARGET message might work although the thrust field is interpreted as speed expressed as a percentage (0 = 0%, 1=100%) of the “default speed” which is WP_SPEED (or CRUISE_SPEED if WP_SPEED is left at zero). There are not a lot of users of the set-attitude-target message yet so we could change how this message is processed.

Hope that helps.

Sorry for late reply, finally had a chance to try it out. Slewrate=0 WORKS! Braking is immediate now with a full reverse on the traxxas controller.

Appreciate the help!

Now, to try and get it to happen over MAVLink…

Servers by jDrones