Transmitter would not reconnect to Arduplane

I attempted a mission.
Arduplane is set to continue on tranmitter failsafe. After takeoff I turned off the transmitter. I had a telemetry connection. I have flown many flights in the hard config of this plane so i am very positive that the video is not interfering with my signal etc.
If you load and play this log (
Question 1
At 25.1% the plane decided to RTL - Why ?
When this happened i entered guided mode on my laptop and set some locations for it to fly to.
At approx 95% on I tried to reconnect my transmitter and manually land. I turned on the transmitter and switiched the mode switch to manual but the plane did not switch to manual. I also tried some other modes.
On the laptop i tried to change the plane to stabilize and control with the transmitter - this didn’t work either.
Finally i set it to manual mode on the laptop and sadly the plane nose dived into a spectacular crash.
At home tonight I tested the transmitter connection to the APM and it’s working fine.
Question 2
Why would the transmitter not reconnect ?

I once have the similar problem. My copter fly well and I try to change to loiter mode.The ardupilot received the transmitter signal and pwm output change to loitter pwm,but mode didn’t change. Finally it crash! :weary:

did you tested also the “transmitter reconnection” after crash? is it working??

In the case to not be able to control the plane with radio I would leave it in RTL or loiter in a safe place to wait until the battery ends. If you have some courage, I would probably tried to land by setting a mission, but I think this is not easy…

When the plane is in automated mode, like AUTO or even in RTL, you are able to move the plane with the radio… even if it is turning in RTL mode, APM leaves you about 50% command with the radio, so you can avoid obstacle, etc… this would be the way to know if the radio is working or not.

I didn’t checked the log, but it seems that the radio link was not working. Have you a servo connected to the receiver rail?

Check the radio reconnection to APM, and try to get off from FS… and see what happen.