TradHeli Changes in Copter 3.6.0-rc1

TradHeli users,
I just wanted to call your attention to the release notes regarding tradheli changes. I made a comment on @rmackay9 blog on the release of Copter 3.6.0 rc1 and wanted to be sure that you see it. If you use RSC mode 3, it has been changed to a 5 point spline-smoothed throttle curve. Please see my comments here on the blog for the release of Copter 3.6.0 rc1. If you have any questions, don’t hesitate to contact Chris or myself.



Since this is in the TradHeli section, these are the settings for the position controller and loiter controller for New Loiter that worked well in my heli. Please note the speed setting for Loiter is quite important to get the braking to work smoothly. Your old setting for ACCEL_Z_P should carry over to the PSC_ACCZ_P.

The PSC_VELXY_D is a brand new setting (the others were moved to the PSC from old settings) and if too high may cause porpoising in auto flight. Leonard has indicated that PSC_VELXY_I should be half of what PSC_VELXY_P is if you adjust those.



There is also new settings for maximum angular rate in the attitude controller. Left set to the zero default (which disables this setting), they did not affect the tuning of my heli.


The final thing I noted was that the new Smart RTL appears to have a default of 2 meters between accumulated points, and 150 points


I got a MavLink notification from the ground station shortly into my first test flight that Smart RTL was disabled because the “buffer” was full. This feature “backtracks” where the heli flew for RTL, so it may not be all that useful for somebody flying auto survey flights on a grid flight pattern. You can disable it by setting SRTL_POINTS to zero and use the regular RTL.

Would be good to hear feedback from other heli pilots testing 3.6-rc1. After yesterday I have accumulated slightly over 2 hours of flight testing, mostly in Auto Mode, and have found nothing that I consider to be an issue. The EKF altitude estimate problem many noted in 3.5 on Auto flights appears to have been resolved in 3.6 with the updates to the EKF.

This was my first successful Auto flight with 3.6-rc1 after tuning the PSC and Loiter controllers. I flew two additional flights of longer distance and duration of a little over 45 minutes each yesterday in much stronger wind gusting to 22kts. The longer flights duplicated the accuracy of this first one.

All the flights were flown with piston heli with the governor disabled to test the performance of the new five-point throttle curve. With the new throttle curve tuned properly it maintained headspeed 1,580 rpm, +5, -10, in my Raptor 716 no matter if it was in cruise flight, descending glide cruise, or making hard climbing turns where it pulled some serious collective in the wind.

1 Like

Amazing the speed how things get tested and the new info comes out now.
Thank you Bill and Chris!!

It’s loaded on my Protos and I should get out testing it in the weekend.

Finally got it out today.
Just finished processing logs/video

Log file

Will add comments tomorrow.

Was late and I wouldn’t have access to vid/log during the day today, so:
Protos 500, 3.6rc1. This, fully loaded is about 3.1kgs and runs at 2150rpm, so not the most agile heli in the world.

Normally the wind dies down in the evening, but not that evening, which made it all a bit more tricky. I had to add a bit of yaw VFF to make the tail behave (I’ve had that issue before on this heli) and in general it looked more unstable…but then I’m now also used to my Soxos600, which is solid in comparison.

After doing the compass dance and re-trimming the AHRS, I played around with the values a bit.
Now again, bear in mind that I’m not really a heli-pilot, so I wanted fairly dumb settings.
BRK_DELAY of 1 was way too much and I ended up with 0.5, which may still be a bit high.
I also decreased ACC_MAX to 300 and I think I reduced the BRK_JERK to 125.
Conditions were not ideal by any means and it was fighting the wind a lot.
Once it was handling reasonable, I then spend the second battery flying around in FPV. Unlike old loiter, where you clearly just ‘pushed’ the heli, this feels a lot more like flying. The balance of the controls is very different than my racing quad (obviously), so it’ll take some time to get used to, but it’s definitely now a viable mode to fly in. I’ll take the gimbal off next time and crank the speed (and headspeed up) and see how it behaves. My only real complaint is that the collective is sluggish, so you have to think ahead by quite a lot with regards to altitude changes.

LOIT_BRK_JERK of 1000 will take your breaking acceleration from 0 to 300 in 1/8th of a second. By setting LOIT_BRK_JERK of 125 you will see it transition over over 1 second.
LOIT_BRK_JERK of 250 gives 0.5 seconds.

From your log, it looks like you reduced braking accel to 125, not the brake jerk. How the braking works is highly dependent on the loiter speed setting. We’ve found that using a higher speed setting of 3000 gives more optimum and smoother braking action. That was recommended by Leonard.

From your log, it looks like the Position Controller was performing optimally.

After about two weeks of testing, I used the CUAV Pixhack nano + Kbar 5.3.4 Pro configuration on my T-rex 500Pro DFC in my spare time, in Pix+FBL mode;And in another T-rex 700DFC Using the configuration of the CUAV Pixhack V3 above, it was very embarrassing to test the flight performance of the latest 3.6rc1 FW and it felt great overall.

The new Loiter model is really good, the maneuver is very agile, the loose rods stop immediately, Loit-related parameters are also very effective. In the forward flight route, it was discovered that during the forward flight, the rudder was operated and the aileron was linked to achieve a beautiful arc turn. This was also the case in the Poshold mode. The rudder turn would not be operated as before, and the aircraft would have to use inertia. The side drift is very far.

Then, at the same time bring two problems:

  1. In the Loiter mode, the Pix+FBL system operates the rudder to perform an in-situ spin. After 2 or 3 laps, the aircraft will seriously nod forward and backward, rather than a stable level of spin. Is it caused by rudder operation linkage? If it is not in the front flight, the operation of the rudder is still linked to the aileron, it is not suitable, and the aircraft cannot rotate steadily. I don’t know if it was caused by the spin correction that comes with the FBL system. I need to test and verify it under the standalone Pixhack system.

2, or Pix + FBL system, under 3.6rc1 FW, Acro mode, after the power self test, the swash plate will be severely tilted to the right and back. Switch to stable mode, the swash plate will restore a certain level, but there will still be a certain degree of tilt. When this causes manual takeoff, pilots must make timely corrections to take off safely. I tried to close Hover_Roll to 0, and the problem still exists. And this problem has not occurred on an independent Pix system, is it also caused by the FBL system.

Increased max speed to 30m/s and it’s much more agreeable. I really like this new loiter mode.

I’m also going to update to Copter 3.6.0-rc1, but I’m not sure, if the problem discussed and solved here (Thank you, Bill!) is already part of it. I guess so, but I couldn’t find it in the release notes. Just to be sure…

Hi Felix,
That fix made it into the code after 3.6-rc1 was released. So it won’t make it into a beta version until 3.6-rc2 is released.

Hi Bill,
thanks for the info. I’ll stay with 3.5.5 then until 3.6-rc2 is released.

Copter-3.6.0-rc1 will allow you to arm with the motor interlock enabled. This means that your heli will immediately start turning rotors. We consider this a safety issue. @ChrisOlson and I are trying to track down what is causing this. Please be aware of your motor interlock switch prior to arming.


Randy merged the fix for this into master a few hours ago. So it will be fixed in 3.6-rc2.

We’d like to hear reports from users testing the 3.6 betas - problems, comments etc…