Tracker issue...not tracking

Congratulation Rannd.

I just got the Pan and Tilt Antenna Tracker kit from Readymade RC. Am in the process of assembling (see attached photo). Will mount the Pixhawk and other gears on this tracker rather than gluing them onto a board for bench testing last year

I have not been successful duirng bench testing. Please help me during set up and testing on this actual tracker.

By the way, what pan and tilt servos are you using, and what are the angles of rotation for the 2 servos ? Did you modify the servos to increase the angle of rotation ?

I use Tower Pro MG996R digital servos with 13 kg-cm torque @4.8V. But as normal servos, they only rotate around 60 degrees which is not enough.
Thank you.


Apologies for the slow response. I have been travelling.

I am using a modified HS-5485HB Pan servo, which has been modified for 360 degree rotation with an external potentiometer on a superseded Servo City 5:1 Servo Gearbox.

My tilt servo is a 180 degree HS-645MG.

Tracker 1.1 has just been released for testing. You can try that, or you can try my modified V1.0. Let me know if you want a copy of my code.

Regards, Don

Hi Don,
Thank you for your reply on servo last year. I stopped working on the project last year because of personal reason, and now pick it up again.

I assume you have been successful in getting the AT working. I just posted a question 10 minutes ago in this forum with the heading " Test button not working in Antenna Tracker Extended tuning page".

Can you help me trouble shoot the problem.

I have been successful to display both the tracker and the vehicle on MP, by changing in the drop down menu below the COM port/speed of MP. But making the servo move with the TEST button is the very first step to make the tracker tracks.

Appreciate your help.

I have a very similar set of symptoms to this, so if anyone worked it out I’d love to hear it. After having a number of problems getting everything set up, the tracker is ‘working’ in that everything tests fine and the tracker can ‘see’ the target via mavlink. But it refuses to ever point at the target. A screen shot shows what’s happening I think.

Doesn’t matter how many times I reboot, arm, disarm, change modes etc… This is in ‘auto’ mode.

same symptoms as in the previous picture, current heading to not move. Tracker do not track. I am also using a continuous servo for pan which is reversed (lower pwm makes it turn to the left). I tried to set -1 to RC1_REV, or SERVO1_REV, switching pwm min and max but no change.

1 Like

logs would help us diagnose along with a picture or description of the setup

edit: @Adam_Kelly on a second look it could be that the copter is within the minium distance for tracking DISTANCE_MIN defaults to 5m. If the target is inside of this radius Tracker wont track. Hard to tell from the scale, maybe it is outside and its something else.

Hi Peter, in the screen shot the copter is ~20m away. I have tried various distances. I’ll see about getting the log and uploading.

1 Like

@iampete I am also experiencing similar issues. Tracker 1.1.0 on Pixhawk v1 with a PT785-S tracker frame. I have the tracker connected to a SITL running current Plane. Telemetry data from SITL is being sent via RFD900+ to tracker. Connection from Tracker to Mission Planner is via USB cable.

The display on Mission Planner seems correct with the orange line tracking the simulated vehicle. With the Tracker armed however, I am only getting oscillation in tilt and no movement in pan. It seems somewhat erratic though as I have previously experienced simultaneous oscillation in both pan and tilt. Unfortunately I did not have an SD card in at the time.

The log is here (Google Drive). Any advice would be welcome.

Ok so I eventually sorted mine out and it now tracks pretty well, although the yaw is a bit slow and it still needs a proper tune. Here’s what I did:

  • reset params to default
  • set my AHRS yaw to 90º (which is correct for my build)
  • did the accelerometer and compass calibrations as per the guide (
  • selected ‘Position’ for servo type (mine are HS-785HB type)
  • left the other values as default in the extended tuning page
  • armed and made sure it connected via the 3DR radio to the vehicle.

And once I got the vehicle far enough away from the tracker it fired into life and started following the vehicle. Success!

A few things that I noted:

  • trying to reduce the distance at which the tracker will track the vehicle in the parameters to <5m is bad. The tracker goes wild in short, sharp movements and never settles.
  • Although my servos are capable of multiple rotations they aren’t ‘continuous’ - they are what the firmware calls ‘Position’. This was the main thing I was doing incorrectly I think. The spec sheets of the servos weren’t clear but after watching a few product reviews for them I picked that up.
  • I’m still very confused about the process of setting the servo PWM values and range of movement. If someone is an expert on this and/or there’s a video explanation it would be great to see someone following the process as it’s meant to be done. I mucked about with this and the PIDs for a full day and never got it right. That’s when I wiped everything and started again.

Thanks to everyone on this thread and the other antenna tracker threads here, on github and diydrones because I think I’ve read them all now! Hope this info helps some others.



nothing obvious in the logs, probably just a matter of getting the tune right, you can set GCS_PID_MASK to report yaw or pitch PID’s. Then tick the tuneing tick box on the lower left of the main map. You can sellect pid actual, desired, p, i and d. That should give a insight into what is going on.

We could do with a updated tracker wiki page, quite big job tho

this is just a matter of GPS accuracy. The position noise results a larger change of angle the closer you get. You may be able to improve this with the PID filters.

A better way to explain the difference is that a position servo will be at a constant position for a given pwm, a ‘continuous rotation’ servo will turn at a constant speed at a given pwm.

1 Like

Hi Peter - thanks for that info. Yes I think once it gets <5m the PIDs just don’t cope very well. Leaving it set at 5m seems like the easiest way to keep it happy.

Learning lots about lots, just following the process of getting this working. Looking forward to using it on the weekend as part of a larger series of tests.

I’ve been working on a few AT projects this past month, and can use some help. I have no previous experience with coding, and have figured everything out on my own so far with the help of this forum.

Through way to many hours of trial and error, I got it to work for Pan, but getting the pitch to work has me ready to scrap the whole thing.

I’ve tried using postion and continuous rotation servos for the pitch. I was never able to get the position servos to work right. I recently switched to a continuous rotation servo (HSR-2648CR) and somewhat had it working. It would accurately track a sim plane at altitudes above 200m, but not below, regardless of PID or max/min pitch settings. After taking a break for an hour, I fired it up again and now I can’t get it to track pitch at all.

I would welcome any suggestions! My setup is below. Please note, I changed the layout after the photo. The PX4 now sits on the tilt frame and moves with the pitch.

I also would like to know how to disable the internal compass on the PX4 and only use the external compass in the GPS puck, so that I can swap them so only the GPS puck moves with the pitch.

Physical Hardware Setup

•Custom designed gimbal frame, 3D printed
•Pixhawk 4 Autopilot w AT 1.0 firmware
•Mission Planner, latest release
•Hitec HSR 2648 continuous rotation servos for Pan and Tilt.
•Holybro sik Telemetry (vehicle to AT)
•OLED display on i2c.
•5000mah 3cell lipo, PX4 power module, Castle creations 10 amp BEC @ 5v feeding the servos.

For the Sim:

•I run two separate instances of MP with AT firmware on the computer.
•One connected to the tracker via USB for adjusting parameters.
•The second running the same AT firmware Sim with Plane, circling my house at various altitudes with a radius of 200M. MavLink telemetry from Sim is sent to the actual tracker via a Sik radio connected to computer via USB.

image image image image image image

please see youtube link below… I’m using an adrupilot for the tracker. It’s powered via a 2s battery. The servo on ch2 buzzes (disconnected).

Am I doing this right? The documentation doesn’t really describe how to setup or operate?

FYI, I just added a post with step by step instructions for AT sim👍 Let me know if this helps. I’m trying to build step by step documentation for AT since there isn’t much that exists with specific details. Please feel free to add to it!

Just sent you a message

Hi Ian,
I modified the pitch servo to 180 deg rotation by adding 2 resistors. But the tracker still does not pitch, only yaw. You mentioned you had some limited success using continuous rotation servo.
Do you think my modification to 180 deg does not satisfy the requirement of continuous rotation servo, and recommend to buy a true continuous rotation servo ?
What about modifying it to 360 deg rotation ?

Looking at the photo you sent me of your setup, my first thought was moving your GPS mount location so that it moves with the pitch.

I had the same issue as well at first. Since the AT uses acell/gyro data to calculate movement, the pitch will not move unless the GPS module is moving with it. Even if you disable the compass in your GPS module, it still will not work. I would try this first and see if it solves the problem.

Thank you Ian for your advice. It sounds very logical. I use another GPS module and have it mounted on top of the Pixhack so it moves with the pitch. See attached link for the photo.

Will try it out at the field tomorrow as it rains in Vancouver today.
Can you share the PID of pitch and yaw of your setup for my reference.

Two questions :

  1. it seems changing the range in the Mission Planner does not have any effect on the actual range of movement in the servo DURING TESTING on the bench. eg. I limit the pitch to -30 deg to +30 deg. But when I push TEST button, antenna pitches much more than + or - 30 deg. Any experience on this ?

  2. Is the horizontal position of the antenna regarded as zero deg for pitch, and minus for antenna dip down below horizontal, while positive pitch for antenna raising above horizontal position ?
    Thank you.

Take a look at this thread…I think I may have responded to you on the wrong thread.