Servers by jDrones

Tracker issue...not tracking


(Kyle Matthew) #1

I got the antenna tracker working, somewhat, when i take it out side and hit auto it just pitches up and down over and over. Video is here: https://www.youtube.com/watch?v=pGHtZj6Xi64

The set up right now is like this:

AIR
-900Mhz 3DR telem radio (Net ID 9) connected to Telem 1 Pixhawk 2.1 in airplane

GROUND – Antenna tracker (Servo City PT785-S Pan & Tilt System)
-900Mhz 3DR telem radio (Net ID 9) connected to Telem 1 Pixhawk (running tracker V 1.0 firmware) on tracker

-900Mhz 3DR telem radio (Net ID 3) connected to Telem 2 Pixhawk (running tracker V 1.0 firmware) on tracker

GROUND – Laptop
-900Mhz 3DR telem radio (Net ID 3) connected to laptop running Mission planner.

When everything is connected and powered on I can select between the airplane and tracker screen to control both and can see both on the screen.

I connected and calibrated it according to the guide here: http://ardupilot.org/antennatracker/docs/frame-assembly.html

What am i doing wrong? Thanks


(Kyle Matthew) #2

Anybody out there???


(Sebastian Schürmann) #3

Hi,

I can not help you getting the Ardupilot antennatracker to work. I started experimenting with it, while it still was at a low 0.x version. It worked for me in some versions and stopped working with others.
I got 1.0 working on the bench with a simulated vehicle, but out on the field it was more or less erratic. Sometimes it would track quite good, but even during one flight day, after changing the lipo on my copter, it would stop working or do something completly random. So I gave up on it and switched my tracker to u360gts.
Perhaps the antennatracker firmware gets some love from the developers in the future, but do not hold your breath.


(Kyle Matthew) #4

Thanks for the info, are you using u360gts with a Pixhawk? Do you like it? Is it really free?


(Sebastian Schürmann) #5

u360gts runs on a naze32 or flip32 board with some buttons, an oled display and an optional GPS.
The firmware is meant to control a specific hardware setup with a continuous rotation servo with external gears for pan and a position servo for tilt. It uses the FCs (or an external) magnetometer to find the correct bearing, but without tilt compensation, so the tracker has to be horizontal. Since I wanted to use my existing mechanics, I had to jump through a few hoops to get it working. Without external gears, pan would run in the wrong direction and I used a feetech servo for pan, which is not supported, because it has a very narrow PWM range. So I put a KKmini board with openaerovtol in between, to reverse and slow down the servo. Once I got everything sorted, it now works without a problem.


(Frankie Fung) #6

Hi Kyle,
I have similar problem, servos not moving either moving the vehicle on the bench or fly the vehicle across the tracker at the field. Have been testing this AT for over 2 years (on and off) without success.
Following are the details of my AT set up (AT “in the middle” configuration 2 in https://youtu.be/8GCqYTDYZaM, and http://ardupilot.org/antennatracker/index.html ). Also see the 2 attached screen capture, and the photo of my set up (on the bench only).
https://drive.google.com/file/d/1X7DzaeMFjxBlN7_EgWfoezEcOuTsGngx/view?usp=sharing
https://drive.google.com/file/d/1sQk2E1EGQaQOjg8qkH-HSQKBGzHqPbsr/view?usp=sharing
https://drive.google.com/file/d/1dBH7ioQAIVRYohXx2uyk6fZ0ZAjyGAHU/view?usp=sharing

After getting the servos moving, will buy 2 high torque servos and have them installed on a pan and tilt mechanism.

Tracker
• APM2.6 flashed with AT v0.7 (also tried v0.8), and powered by 4.8 volt supplied to APM input pin set.
• Accelerometer (6 orientation) of APM calibrated.
• Compass, calibrated, connected to APM I2C port.
• Telemetry air module (A) connected to APM telem port for tracking vehicle position.
• Another telemetry air module (different Net ID) connected to APM UART0 pin set for link with GCS.
• GPS connected to APM GPS port.
• Pan and tilt servos connected to output of APM. 4.8 volt is supplied to APM output pin for powering the servos.

Vehicle
• A S500 quad, running on Pixhawk , with telemetry air module communicating with the air module (A) on the tracker. Link is established as witnessed from the solid green LED and other blinking LEDs.

GCS
• A laptop running Windows 7, MP v1.3.56.
• When everything is powered up, GPS 3D locked, 2 pairs of telemetry radio linked, right click on the tracker icon on the map in MP and select “Set Home Here” to set home location.
• In “Extended tuning “ page of MP, “Type” of servo” , “Pitch range of movement” and “Altitude source” are all greyed out, not available for AT v0.7
• Yaw range of movement is left at default, 360 deg.
• Servo testing is OK when pressing the “TEST” button after moving the slider to left or right.
• Yaw and Pitch gains are as shown on the attached screen capture.
• Only the tracker icon appears in the MP map. And I seeing both the tracker icon and the plane icon appear on your screen. Kyle, can you give more details on the Mission Planner ?

In your set up, you get the tracker pitching up and down. Did it pitch in response to the plane motion?

I don’t get any movement on the 2 servos. Pls comment on my set up and compare yours with mine. Appreciate if you let me know the differences between our set up. Thanks.
Frankie


(Kyle Matthew) #7

Frankie,
Hi, when i hit auto it just pitched up and down, no response to aircraft movement. I walked the airplane left and right, back and forth, up and down, no tracking.

As for the difference in our setups:
-i’m using a regular Pixhawk on tracker and Pixhawk 2.1 on airplane.
-I’m on Windows 10, MP v1.3.59
-AT v1.0
-My servos also tested fine and i’m able to move it in manual mode but no auto track.
-I can see and switch between tracker and airplane on the “flight data” screen, upper right corner under the com port, using the drop down menu to choose between tracker and airplane for control.

That’s all i can see, but once again, mine is not working so i’m still looking for a solution or someone to help!

Kyle


(Frankie Fung) #8

Hello Kyle,

Where is the “auto” button that you hit ?

Also, in the flight data screen, on top right hand corner, drop down menu under the COM port, I only got Antenna Tracker, no other port.
My telem radio connected to the laptop MP is for pairing with one telem radio on the tracker, while the other telem radio on the tracker pairs with the radio on the vehicle. And I tried plugging another radio to another USB port in laptop at the same time, but the COM port in MP does not recognise it. Pls advise your radio telem set up.
Thanks


(Frankie Fung) #9

Hello Kyle,

Did you arm the tracker in the “Action” tab under the HUD in MP ?


(Kyle Matthew) #10

HI, yes. Then i hit auto and it goes crazy.


(Kyle Matthew) #11

Frankie, hi, Set up like this.


(Frankie Fung) #12

Thank you Kyle.

In fact, I connected the set up the same as yours before posting last time. Somehow no sign of servo moving.

Later on, I don’t know what button did I push, probably the ARM/DISARM button in Action tab in MP, as soon as the telem radio in the vehicle is powered up, the tracker (Pixhawk) emits a sound to signify signal is received. Subsequent field testing, I can see the pitch servo moving as the quad increases in altitude. But the pan servo refuses to move even though I bring the quad across the tracker overhead. SO still have to figure out why pan servo is not moving. But I don’t have the tracker going crazy as you did. My servos are not yet mounted on pan and tilt system, just glued to a cardboard for bench testing.

I don’t see the quadcopter in the drop down menu beneath the COM port because I was using APM2.6 as tracker. Once I switched to Pixhawk, I can switch between tracker and quad.

Good luck.

Frankie