Servers by jDrones

Tracker-1.1 Officially Released

Hi Peter - I had tried not arming and/or disarming with the safety switch but that didn’t seem to help. Your suggestion made me give it another try though, and I discovered you have to hit ‘start’ on the compass calibration when you are not connected to the antenna tracker at all. I’m using the ESP8266 wifi module to connect to MP from the pixracer, unsure if that’s what was giving me the grief. Either way, by hitting start with the tracker disconnected, the connection happens and the calibration starts. At last!
The issue remains that I cannot check the ‘enable compasses’ box - but the compasses are definitely enabled in the params list so not sure that’s a huge problem.

This is not arming/disarming that is just the saftey state. You will have to manually disarm via the GCS.

The HUD shows ‘disarmed’ until I press the switch. But either way, it works by not connecting to the tracker first so I’m all set now.

Hi @iampete thank you, I had the same issue with the calibration on my Mini Pix. @Adam_Kelly It dint work with just disarm but I set the mode to “STOP” and then it allowed me to Calibrate the accel and compass.

Having now worked on the tracker for a couple of days I’ve found the only reliable way to do the compass calibration is:

  • power on the tracker, press the safety switch
  • connect in mission planner
  • change mode to ‘stop’
  • disarm in mission planner
  • use compass calibration button

that’s how it’s working for me, anyway.

2 Likes

Here’s a video where we can see my tracker in action:

2 Likes

Hi I am trying to do 360 degree Tracking. tracker is hitting lower PWM or higher and further it is missing tracking with 180 degree. I did change MIN_REVERSE_TIME parameter to 0 and 1s. in both cases it is not tacking 360 degree after first round. same issue i was facing in V1.0.0 also. I am flashing firmware without chibiOS. Is 360 degree tacking is solved in V1.1.0?

Servers by jDrones