Tracker 1.1 Beta1 Released

thats the old version, MP has not been updated to find the new beta yet. In the mean time you can download the appropriate .apj from here . You can then load it using the load custom firmware button.

i just did a beta update still not reporting
but if i plug in plane or chopper mission planer is reporting them

Michael Oborne has just relased a new beta version of MP that properly shows the Tracker version!

yes it does but does not show whats on the board


OK, so it looks like it reports the version in the Messages tab but it’s not showing it on the upper menu bar of MP. I think maybe I’ll leave that for IamPete and PeterBarker to look into.

i tried my pc as well no luck works fine on plane and chopper :roll_eyes:
does not matter
any way i just upload the beta firmware to my pixhawk V2 it uploaded fine trying to config it and set it up
i cant calibrate the compass’s i am using here gps on it

Cant calibrate the compass’s or Acc on 1.1.0-rc1

hum, not sure why this would be, would be great if you could provide a t-log and a dataflash log (you will have to turn on disarmed logging)

ah that might be it, you have to be disarmed to calibrate but tracker auto arms. You can disarm via mission planners button then try again. Thanks!

How did you connect the Pixhawk to the MissionPlanner? For compass calibration, I needed the USB connection.

work it out disarm is not enough
i had to click on stop as well
but under ChibiOS will not calibrate just get to 100% then starts gain will not Finnish

well after a week stuffing around with pixhawk could not get it to work all over the shop
so i put a cube on it
now all i get is its bad ahrs and all it does rocks back and forth

here some logs

Looks like you could just have a bad tune. Also you have a lot of roll - pitch coupling suggesting the flight controller is not mounted straight or the orientation is wrong. I suggest you start in scan mode, turn the scan speeds down a lot (SCAN_SPEED_PIT and SCAN_SPEED_YAW). Set the gcs PID mask param and look at the tuning screen for actual vs desired. The best place for info on how that param works is here on the rover wiki. A picture of your setup might help diagnose issue, good luck!

here is the setup

looking at the pic i think i am right in saying the gps does not move with the pitch axis?

This will be the cause of your trouble, your using the compass in the gps but it is not moving with the flight controller, this will upset the EKF. Hence the bad ahrs warnings. Set COMPASS_USE to 0.

yep i think you right forgot about that will try later on :+1:

no same thing i set it to the cubes compass

hum, maybe turning off compass use it not enough. I maybe you have to completely disable it with COMPASS_TYPEMASK. I’m not sure which compass you will have in your unit, if your on the latest mission planner you can look on the dev-id page and turn off that compass in the type-mask.

Of course the other fix would be to mount the gps on the pitch axis.

Or unplug the i2c connection but then you also loose the led’s

looks like a cube issue :roll_eyes:

this is a copter log? Copter will like the static compass no more than tracker does, attach the compass to the pitch ‘head’ and redo the calibrations.

i am only using the built in compass in the cube and its mounted on the pitch and yaw
i put choprer on to test if it is a bad black cube in mission planer and it is have look at the logs IMU failed