Tower is crashing when using UVC stream @Android 6.0

I bought USB UVC capture dongle and it is working on my phone HTC M7 @Android 5.0.2. Now I bought 8 inch tablet Lenovo Tab3 @Android 6.0 to have a bigger screen and Tower is crashing when I connect UVC dongle and confirm access to USB device: “Unfortunately, Tower has stopped.” :cry: I sent report from tablet several times…
Any ideas? Is is possible to fix it somehow? Should I return tablet back to the shop?

I see the same crash on a samsung S7Active with Android 6, and now android 7. The UVC device works in other android apps on the same phone.

Hi, i have a same problem with a Xiaomi Mi Max android 6.0.1. Working with another UVC app and my pc

no coming fix ?

I have some problem, it’s happening on 64bit processors, need to compile 64bit of LIBUSB100.SO or recompile it by include this line on build.gradle to exlude arm64-v8a native library:

exclude ‘lib/arm64-v8a/*.so’;

I have the same issue on Samsung S6 with android 7.0

Is there a solution for the android noobs?

I have the same problem on a China Android with custom rom. Still no fix?

Hello, can you rebuild the project and upload apk somewhere pls. I would like to test it.

this is the apk, send me any feedback:



Hello friends this before happened to me, solve the problem for all my mobile and tablet using the version of tower specifies, is previous but works with all current mobile and tablet, using the version 1.5 tower app can download it from google and it will work perfect , Newer versions the tower app goes off

I tried this. The app doesnt crash but I don’t get any uvc video. the video window is just black. Any updates on this?

I am having this same issue has anyone been successful in solving this yet?

I have installed this .apk and it solves the proble with Tower crashing issue on my Samsung Galaxy 6 with Android version 7, and I can now view the video stream.

But when I change the orientation of the phone a message pops up that says “Dumping memory, app will freeze. Brrr.

It seems to be triggered by the change in the size of the video window and I assume that this is from some debug code in the Tower app?

Is there any way that I can eliminate this memory dumping process?

i’ll try to found the issue and then fixit. Stay tuned