Android version that supports UVC ...?

That branch of Tower does support UVC video, but it doesn’t look like it supports Mavlink? Whenever I click on “Connect”, there is a 1 to 2 second delay and then the Chrome browser pops up with their website ( displayed in Chinese …

I can see the video from my camera, but I can’t connect to my PixHawk … one step forward, one step back.

Have you been able to get SkyDroid to connect to your pixhawk?

I hope skydroid vers not support anymore only than their system, there works perfect but I couldn’t connect with other devices with the last vers, Im going to ask to them. Another option is in google play (something with Maker word Im not at home now) or tower in github I search later an tell you

1 Like

Mission Maker for Ardupilot. Haven’t tried it.

1 Like

Mission Maker
None support UVC video. Tried them all.
The Skydroid version supports it, but as Cala2 said It’s not been tried with non-Skydroid equipment but I can’t imagine it not working as its a Mavlink based app.

Not sure if this link will work for you.
if not let me know I have a dropbox version of it.

Also install this
its a UVC app if you need one. not sure if you need the two of them installed together.

Donlakeflyer has the UVC equipment now and is looking into UVC video for qGroundcontrol. No promises he will have a solution. But he is a bright fellow so we live in hope.

I try with last vers with other devices but didnt work, it opened their page, with skydroid no fail issues.

As far as I can tell so far the SkyDroid thing might be a special device which doesn’t really support standard UVC. It requires special code to make it work. If that is truly the case then it may not be possible to support.

Hey Don.
If I plug the Skydroid receiver…which is also the same unit as the Eachine ROTG1 or 2 into my windows pc it works like a charm with no added driver or Skydroid application.
So not sure it needs anything special to run it.
But that said I am not a programmer so I could be wrong.

That seems to be only true on Windows. Not OSX for example. Not recognied.

I hope the issue is with tower skydroid new vers app that not connect to other RModems but not the video unit, that looks standard 5.8 ghz and connect to any video app, I m going to have in my hands on week end and can do more tests, to mission planner connects well.

I have been doing some more testing of GCS’s with 2 Samsung Galaxy phones that I have - an S4 and an S6 and I have found that Mission Maker for Android works fine on the S4 (Android ver 5.0.1) with both the telemetry radio link and the UVC video. However, Mission Maker crashes on my S6 (Android ver 7.0) and I remembered an issue that was reported last year about Tower needing to be recompiled for the 64-bit S6.

A recompiled version of Tower (ver 4.0) is available here Tower is crashing when using UVC stream @Android 6.0.

I originally couldn’t get the UVC video stream to display because I also needed to go into Settings > User Interface > Widgets preferences and select UVC Video. Now Mission Maker works fine on the S4 and the recompiled Tower works fine on the S6 …:grinning:


For what it’s worth, I just ran it on a Samsung Note 8 and it seems ok. I do not have video to test. Thanks for sharing this good news.

So now we have two versions of Tower UVC works on. WE just need QGroundcontrol to work.

What UVC device are you using?

It’s an EACHINE ROTG01 5.8G 150 channel OTG UVC receiver. Both the radio telemetry receiver (SIK Radio clone) and the ROTG01 are plugged into an OTG micro USB hub which is then plugged into my Galaxy S4 or S6 phone.

It works fine now that I have set it up correctly, except that the recompiled Tower running on the S6 causes the following message “ Dumping memory, app will freeze. Brrr. ” to appear frequently and I have no idea what it means or how to fix it. If anyone has some advice on this issue, I would appreciate it?

My understanding is that the development of QGroundControl is done on the QT platform and QT does not support UVC code on Android. I don’t know enough about the multi-platform process to figure out if there is a way of creating an Android version of QGroundControl that does support UVC. For example, can the source code be compiled on a different development platform?

That’s not quite right. Qt supports UVC on Android but only for some devices. I"m trying to figure out why that is but it requires debugging into Qt and then submitting a code change to Qt sources if I ever figure anything out. I’m trying to do that but it’s going to take some time.

1 Like

Ah, so that’s the issue … :wink:

I know that QGroundControl UVC does not work on my Galaxy S6, but maybe it will work on my Galaxy S4? I will give it a try and let you know.

It depends on the UVC device itself I believe not the tablet.

What video source you have to choose for UVC? I have 3.5 vers and can{t find UVC choice. Thanks

Go into Settings > User Interface > Widgets Preferences and select UVC Video in the Widgets List.

If you don’t see the “UVC Video” option in the Widgets List, then you may have to upgrade to the latest version - are you referring to Tower or Mission Maker?

Perhaps I misunderstand, I understand that Don was refering to QGround control (my bad english )