To establish connection between jetson nano and Pixhawk via dronekit

I have installed dronekit package. I have connected Jetson nano to pixhawk via telem2 port using ftdi cable. The baud rate at telem port is 921600. I have written a basic python script to connect to the vehicle.But I am getting the following error. Link timeout, no heartbeat in last 5 seconds
Kindly tell how to proceed about this issue. This is the first time I am trying to establish connection between jetson nano and pixhawk. I donot know how to rectify this issue

from dronekit import connect, Command, LocationGlobal
from pymavlink import mavutil
import time, sys, argparse, math
print "Connecting"
connection_string = '/dev/ttyUSB0'
vehicle = connect(connection_string, baud=921600,wait_ready=True)

What is this? Do you mean USB-TTL?
This is a bare script, if you could not be able to connect to your vehicle, this means there is something wrong with the connection.
Could be a parameter, device permission, or wiring error.
You need to tell more details about your setup.
Simply run MAVProxy as on your terminal.
MAVProxy should be able to automatically find your device.

Yes I have used USB-TTL connector. I ran but i am getting MAV> link 1 down. Can you tell what might be the problem. Is it because I have flashed Pixhawk with PX4

I have connected Vcc to +5V of jetson Nano. The ground of telem2 port to jetson ground and another jetson ground to that of converter. I have given Rx to Tx and Tx to Rx from the converter to jetson nano

The problem is that you still don’t have a connection between the flight controller and companion computer.
Could you please separately try:

  • Set the baud rate on the flight controller to 115200 and try connecting with MAVProxy.
  • Change Tx-Rx wires.

I have mavros installed and I am able to launch it successfully. If the connections were wrong, then this would have also not worked right?. I will change the baud rate of telem2 port to 115200 and update about it

I changed the baud rate to 115200 and i tried running Still the same error persists.

Then you should’ve told us about it.

Now I’m suspecting about mavros connects to the source first then doesn’t give it to the mavproxy, but I’m don’t have any knowledge about mavros.
Are you positive that mavros is down during the process?

Yes i am not launching mavros while testing for mavproxy