Servers by jDrones

Timeout with telemetry no matter what

Hi,

Now I dont get it.
Two different computers.
Four different telemetry SIK-radios.
Two different Micro-USB-cables.
Net ID 25
57600 baud and the right COM-port.
Loading and saving settings, Copy required to remote.
Same settings on all as before when all worked.
Two different versions of Mission Planners (the two latest).
Two different UAVs (a plane with an old APM and a multicopter with a Pixhawk 2.1).
Restarted all a few times.

I get timeouts not matter what I do.
No heartbeat.
I cant get anything done.

Try these and see if it helps:
BRD_SER1_RTSCTS,0
BRD_SER2_RTSCTS,0

The only thing that has changed are the newer versions of Mission Planner on both computers regarding the plane, which havent had a USB-port for years, over-used and the plane is used for mapping, I just connect and fly. I cant set those parameters on the plane.

On the multicopter, the firmware is also new (4.0.5, before 4.0.3). This one worked fine before upgrading to 4.0.5 using the same Mission Planner. USB works fine.
Changed the parameters you suggested, no difference. :frowning:

The radio connected to the computer blinks green 1Hz on all radios and on both computers when trying to connect to both plane and multicopter. The LED on the radio on the multicopter blinks green 1Hz and the red double blinks at 1Hz. On the plane the green blinks 1Hz and the red blinks constant at a faster rate.

I cant mark and copy the details on the “No Heartbeat Packets Received”-error. Have followed the instructions there.

Have you re-granded access to mission planner after update? The classic pop up that you may just cancelled…

If you did try uninstalling MP and install a fresh copy, or even beta update it.

Usually it’s one of those.
Before you do all those, disregard lights and colors and just go to optional hardware tab/ sick radio and hit load, to ensure both units are populated with data.

Best of luck

Have never heard of “re-granded access to Mission Planner after update”, how do I do that? Havent seen any classic pop up besides the timeout-popup.

Have reinstalled Mission planner on both computers and even the beta on one, but not today, that was around two weeks ago.
Have hit load at numerous times on all SIK-radios during my search for error since no one works suddenly, even with the one in the multicopter. Have only changed Net ID since I use two different. The rest looks at it have always done.

I guess it is the new Mission Planner that have done something, that is the only common denominator.

Could it be the Windows 10 driver that ruined it all? Both computers was probably automatically updated simultaneously. Which one is it and where can I get it if that is the case?

There are no new updates for the Mission Planner on both computers.

If all radios have the same settings then they should get a solid green LED even with only power, regardless of other wiring or PC drivers.

I have different radios, all of them dont have a power-LED. But all have worked.

I just tried on another multicopter that worked fine before.
Did it work now? Nope!

I used the two radios I have used before on that multicopter.
I loaded settings, changed them to be identical (max frequency was lower than the min frequency), saved settings and also uploaded firmware.
On both.
After they connected and the voice said “Stabilize” for the flight mode and then “getting parameters”, it continues “getting parameters”, Ctrl+Alt+Del next.
Restarted everything, then it all worked.

Why?

Next… do the same on the others… but I dont know why I have to do it. Something must have changed, anyone know what?

Well, now I did this.

Connected every SIK-telemetry-radio I got (also on the copters/planes) with USB-cable and:

  1. Upgraded the firmwares from 1.6, 1.8 and 1.9 to 2.0 on all.
  2. Same settings on all

Now they work! But in a way I like, took some time. :slight_smile:

But why they all stopped working, I dont know. Must be because of the upgraded Mission Planner to the latest version or Windows 10 update messing with something

SOLVED!

Servers by jDrones