Timeout waiting for autoscan/no mavlink device connected

Just purchased a quanum nova pro, I’m trying to connect it to mission planner but I keep getting this message Timeout waiting for autoscan/no mavlink device connected. The computer is picking up the drone connecting via usb

Cheers

Try manually selecting the com port and 115200 baud rate.
If that doesn’t work you might need a powered USB hub.

On the connection drop down the only options I’m getting is auto,tcp,udp, and udpci. I’ve also tried doing it with a battery connected

Windows hasn’t recognised the autopilot. Try another USB cable and port, but you may need to reload the drivers.

Finally got it sorted ended up downloading arduino in order to get the correct driver for the drone now it works perfect

did you install Mission Planner from the MSI? or Zip?

I used msi to install

Hi Alex, This is an old thread but I have the same issue now. When I try to connect via USB, it says “timeout waiting for autoscan/no mavlink device connected”. What do you mean by “downloading arduino”? Is there an Arduino driver that my computer needs in order for it to recognize the flight controller? If so, what is it and how do I download it? Thanks
PS: whenever I try plugging in my flight controller, no com ports show up on my computer.

1 Like