Thrust loss during autotune

I had a similar problem on my tarot 650 Sport with APD40 escs. Turns out I was saturating the escs with current when recovering from the auto tune dips. I had forgotten to put caps on all the escs. Adding them back in smoothed out the response and fixed the issue completely.

you guys rock, I successfully autotuned this morning

here are the changes I made prior to the success:

  • I lowered the MOT_SPIN_MIN from 0.15 to 0.06, lowered the MOT_SPIN_ARM from 0.10 to 0.03
  • changed rampup power in blheli from 50% to 25%
  • changed PWM from 24 to 48khz (that was my max available)
  • changed motor timing to auto
  • turned auto telemetry ON
    -also turned on sine modulation mode, whatever that is, per the previous advice

Not sure which of the above (or more than one) fixed my issue, but it flew fine this morning, stability problem resolved. big thanks to all of you!

1 Like

Auto Telemetry wont be needed if you are using DHSOT - the flight controller will request the data via DSHOT commands.
Some have found that the Auto Telem can overwhelm the serial port.
Everything else sounds good.

@xfacta thanks I was wondering about that, I’ll turn auto telemetry off.

Just keep an eye on the MOT_SPIN_MIN value in particular. If you are descending fast the props might spin backwards if the ESC/motor combo is not powerful enough to keep the props turning in the correct direction at that very low RPM.
Maybe set a high-ish MOT_SPIN_MIN and try some descents with lower and lower values to check if descent performance matches your expectations and motors don’t lose sync.
MOT_SPIN_ARM is not critical, as long as the motors reliably start.

okay, I turned up MOT_SPIN_MIN from .06 to .08 and MOT_SPIN_ARM from .03 to .05… and promptly crashed again on autotune (trying to finish the yaw axis). Am I really crashing just from turning those two parameters up by 2%? @Giaco I checked and I did remember to install my cap, you had me worried for a minute there but I did remember.

So I’ll turn it back down to .06 and .03, and see whether the problem goes away, and report back after tomorrow morning’s session. Seems like something else must be going on, though, right?

MOT_SPIN_ARM makes no difference. It’s simply an indication that the motors will turn upon arming. You can set that to 0 if you don’t care or anything below MIN if you do.

What props are on it now?

Got a 6S Lipo battery to try?

i’m using 6S li-ion. I could try li-po. I’m assuming though that you were suggesting moving from 4S to 6S rather than li-ion to li-po?

still using the 15x5.6 t-motor

Do we think this is a de-sync? If so it feels like whether you get a de-sync or not is going to be fairly random. Correlation is not causation.

1 Like

Suggest trying 6S Lipo.

And perhaps just manual tune regardless.

Ok, went back to .06 and .03 for MOT_SPIN_MIN and MOT_SPIN_ARM because that seemed to work once. Definitely unrelated; I crashed during stabilize this time. So it’s not autotune and not the parameters above. I wish it were specific to autotune, in which case I could resort to manual tune, but this morning ruined that notion. I think this was the first time it happened aside from autotune because I hadn’t been sufficiently aggressive with it until this morning.

I wouldn’t know what a desync looks like… doesn’t that occur at high rpm rather than low? What can I do to diagnose desync? Should I fix the motor timing at a specific number, for testing purposes, instead of using auto? Try 20 degree? The default was 16, and now that it’s on auto I don’t know what it was using. I’m grasping at straws now.

Could this be intermittent motor wiring? These particular t-motors comes with short wires that are solid conductor 20awg (or else so tinned it might as well be solid), so they don’t give the warm fuzzies regarding the soldered mechanical joint. These are the least ideal wiring I’ve encountered. I may re-do them with small crimp connectors, maybe also filled with solder, as that actually seems like it might be mechanically superior to soldering alone in this case. But I’m skeptical that this is the problem—I would expect motor failures more randomly. What symptoms should I expect if it were a crappy motor connection?

I’ve got my motor wires twisted nicely all the way back to the ESC. This is the first time I’ve done that, am I changing the inductance enough to affect motor sync?

My failures are very specific to attitude stability, and it seems to occur when one motor (though not necessarily the same one) tries to recover from low rpms. It seems like a motor cutting out when attitude recovery should be occurring—it doesn’t try to wind up and then fail to stabilize, it just seems to… give up. I will try to get a decent video of it, if anyone thinks that would help.

Also, @dkemxr I will try the lipo instead of li-ion, I have one available and I want to do a video of the problem anyway so it’s an easy test. Maybe the two 4000mah li-ion in parallel can’t source the recovery current fast enough, though that seems unlikely.

One other thing to throw into the mix—the arms on this are longer than they need to be. I sized them to be able to fit 18” and I’m flying 15”. Generally I would think this increases stability, but it does also add increase the moment which presents greater resistance to rotational acceleration—thereby loading the motor more for the same rotation than if I had shorter arms. It’s easy enough to shorten the arms, but I thought I was doing myself a favor. With the longer arms I can swap out the motors and put 18” on there if I want to carry more weight someday in the future, but if I cut the arms I lose that option. But if the consensus is that my arm length is a problem, I’ll definitely chop them

Hey Matt-Post another log of this latest crash. Perhaps desync is the more likely cause but honestly I don’t have much 1st hand experience diagnosing this.

I went through DeSync before.
In my case it was on 18 inch props. But I can tell you that one motor goes high and the other low in an effort to counter the sudden drop of an arm. Also there is a slight change in noise, it’s an odd sound.
It may report in the log as thrust loss.
I had it happen in Stabilize mode in breezy conditions and low speed. The drone was trying to compensate for the wind and as it tried to spin up or down to deal with the wind. It desynced and crashed. In my case I was 2 feet off the ground and so it just settled to earth.
I have not had it happen again since changing the demag compensation…Also something else.
Sorry I don’t recall…I think it was PWM and timing.
Your problem sounds exactly the same. The machine is working well and then suddenly the motor just slows down while it’s trying to keep up with the FC requests. I didn’t say anything sooner cause these other guys are way smarter then me. But it sounds exactly the same. I actually caught it on camera.

I tried with the LiPo, no difference.

ok here are some more logs:

Most recent crash, this afternoon, hot off the press (two crashes for the price of one), in stabilize.

Yesterday’s crash.

My one successful flight, autotuning.

@rickyg32 thanks for chiming in my crashes definitely look like yours, though it might look similar from different thrust loss causes I would guess. Desync sounds promising to me at this point, but partly that’s because I don’t know anything about it. I didn’t notice any particular strange noise, but that might just be my lack of listening.

I’m going to read up on desync and blheli settings now to educate myself, then I’ll mess with blheli and go try to crash again.

progress! I’m hesitant to report success (I made that mistake once already), but I had a good long flight without crashing.

Exploring the idea that it might be desync (thanks @rickyg32 for supporting that hypothesis) , I read up on the blheli settings and changed the ones that might help mitigate desync (see screengrab below).

  • I increased the timing from 16 to 24 degrees
  • increased demag compensation to high
  • reduced rampump power to 12%
  • set maximum acceleration to 15% per millisecond

The changes definitely seemed to have made a difference. I got increasingly aggressive as my confidence in the stability increased. I did reach a point where my aggressiveness threatened the stability, but it was at a much higher level than that which has been causing crashes. Now the quad acts more like I would expect out of a low-performance, long-flight-time build.

My current hypothesis on what the problems were/are is two-fold:

  1. I was suffering desync, which I may have remedied
  2. my thrust:weight is definitely on the low side, as has been mentioned by a few of you, which gives me less overhead for aggressive flying, which means that everything has to be dialed in appropriately and I’ll need to be conservative. I think it would be a good idea to hamstring the loiter performance a bit in order to avoid trouble, perhaps putting in an angle limitation? As mentioned, this is intended for search and rescue operations, not racing or freestyle. Obviously it has to be stable, but I don’t need this to fly like my 7" freestyle build with 12 minutes of flight time.

I will fly the same thing again tomorrow, to see if I can repeat the success. fingers crossed that this is real progress though

1 Like

If you are running 7inch so I prefer
Ramp power should be 30 to 40%
Motor timing nearly 20 to 22
Demag compesatio = medium
And sine modulation it’s worst on dont enough thrust value on your copter

Try is and let me know what happens

update : I took the “barely adequate thrust” message to heart, and a swapped out the motors. I took off the t-motor 4004 KV300 and put on the 4004 KV400. This improved the situation considerably. I am much more confident with the flight characteristics now. I believe the overall improvement was equal parts blheli settings and motor change.

Given the improvements that transpired after blheli mods, I’m particularly excited to tweak things as per @Moksh suggestions, thanks for those and I will report back when I get a chance to try them.

thanks to everyone for the expert advice. I’m still having other issues with telemetry dropping out, but I’ll start a separate thread when I’m ready to ask some questions on that topic.

1 Like