Throttle-Tracking Notch when flying with Mavlinks MANUAL_CONTROL

Hi,
we are using MANUAL_CONTROL to control our Octocopter and have set up notch filtering. When loading a log into the filter review web tool, I get the

No tracking data available for Throttle notch

error message. Is it simply not logged when using mavlink? Or can it actually not be used for that?

If anyone needs a log, I can share it privately.

It has nothing to do with MANUAL_CONTROL, just follow Methodically configure and tune ArduCopter and do it correctly.

I have followed that excellent guide to the best of my knowledge and ability (and sped up the process with some prior knowledge from a very similar copter we built previously).
I would have preferred to have RPM tracking, but we have T-Motor Alpha ESCs, so no RPM tracking for now until we add the Data Link.
If you could point me to the step where I could have missed something, that would be great!
I will check if it’s the log bitmask, I don’t have any more ideas for now

Yes, the problem is that you did not load the 13_logging.param file.

grafik
Here’s my log bitmask, with RC input I would expect it to get logged

RC Output is missing
LOG_OPTIONS 4 might be missing as well.

Ah, I modified that value and didn’t expect to need RC output.
INS_LOG_BAT_OPT 4 is there

RC Output was the thing missing, thanks for the help!

@amilcarlucas thanks for putting together the drone configure and tunning post it is an excellent document.
I’m having the same issue that @WARGRaph mentioned and I reviewed my 13_logging.param file but the RC out is enabled.
Here I have a log file. Any advice on this is greatly appreciated

Please post a .zip file with all your edited .param files.

Here it is
ivan-4.4.4-params.zip (52.3 KB)
Thanks for taking the time to look into this

Good job :clap:, you understood the concept and updated the comments, so I could follow your reasoning in the decisions you made ! :+1:

on 07 why not restrict GPS_GNSS_MODE ?
on 11 Excellent, you understood the idea !!
on 16 INS_HNTCH_REF should be the expected MOT_THST_HOVER because you have no ESC telemetry

Thanks. This document a procedure is worth the time of reading thoroughly.

For GPS_GNS_MODE I went with the default but I think I’ll change it to 65 (GPS + GLONASS) since it has been mentioned in other forum posts and it is compatible with my Here 2

As for INS_HNTCH_REF this went over my head, I re-read this Throttle Based Dynamic Notch Setup — Copter documentation and I’ll try a value of 0.2 to begin with.

Now doing this changes should fix the

No tracking data available for Throttle notch

from the ArduPilot Filter Review Tool ?

Thanks for taking the time to review this

yes, it will probably fix that

I just finished some test hovers and I got the same message:

No tracking data available for Throttle notch

I’ll review this in more detail what could be causing this. If there is any other advice that what I could check I would appreciate it a lot.

Can I include your parameters as an example on GitHub - ArduPilot/MethodicConfigurator: A clear ArduPilot configuration sequence ?
And release them as part of that software under the GPLv3 License?
Do you have a newer version of them?