Throttle runs away, does not respond to RC input

Hi, I am new to APM, and am having problems with my Tarot 680 Pro Hex, APM 2.6 with 3.2.1 firmware and TH9X radio flashed with ER9X.

I maidened the hex on Wednesday, and crashed on take off as I did not have the pitch control det up correctly (stick forwards = low). I inverted channel two in ER9X, and this appears correct now in mission planner > radio calibration. This crash landing broke my landing skids, so I had to wait until today for a new set to arrive.

I tried a tethered flight to check all was ok, but sadly it wasn’t. As soon as I tried to throttle up to take off, the throtle rapidly went to full power without any input from the transmitter, and would not respond to my input.

I switched modes to see if that made any difference, but it did not. The motors then slowed to idle, and I un-armed - I do not know if the motors slowed as a result of something I did, or on there own.

I can’t make any sense of the logs, and wonder if someone could help me out here. I have attached the log file below.


Although not many logs are enabled it looks to me like battery failsafe. your battery voltage starts low assuming its 4s…and then takes a nose dive to 10V…which is low for 3s let alone 4s.

looks like your battery isn’t charged

Thats odd, because it has been freshly charged, and reads ok on my multi meter.

The logs are whatever was enabled ‘out of the box’ - how do I log more functions?

On the logs read the wiki and consider that with APM only enable logs that are beneficial due to limited processing power. But I don’t think more logs will diagnose this issue any better. Look at volt plot within curr. You can see the voltage drop. Test the battery, test that you don’t have high resistance in the wiring between the battery and power module, and test that the power module reads the same as your Meter. Can you strap it down and test under load on the bench? Be careful of live spinning props and things that can be blown about.

sent from my phone so apologies for any typos

I found that the battery (Fluoreon 4S 5000mAh) had a duff cell (No. 3) and as this was the first time I’d used it, I was a bit pi$$ed off.

I contacted the seller, and they sent a replacement battery after a few days. I have not been able to fly again yet, but hope this issue is resolved.

OK. Glad you are resolving it. Maybe consider using external LEDs. Might provide earlier warning if it was to happen again.

sent from my phone so apologies for any typos