Throttle problem

When I arm my pixhawk, my motors spin pretty fast maybe 20-25% of max with throttle stick at minimum. I’m running ardu copter 3.4.5 and my TX is a taranis. I’ve read that I need to set my min throttle lower, but I’m unsure how to that.

Also, my pixhawk will disarm if the my throttle stick stays at the min position for 30 seconds or so. What setting is that called?

Hi Shane,

Please read this page: http://ardupilot.org/copter/docs/set-motor-range.html

I need a little more information, when does that happen?

Hi Franciso: I solved the motors spinning on armed. Here is a video of the no throttle/activity disarm:

What mode are you in?

My mode is Stabilize.

We have a disarm delay of 10 seconds if you have your throttle at zero for that long. That’s configurable, maybe you changed it? A log will tell more.