Throttle / Power management for beginners - Arduplane VTOL

I’ve had this problem before and still can’t tell what I should do.
When I’m using a high power battery like a 5S or 6S it’s impossible to control the aircraft, I’ve done already a VTOL aircraft and managed to fly it and even make a transition to forward flight but with many problems (spins out of control during transition).

This time I decided to create a test frame just for the sake of saving my planes, and test the VTOL firmware specially the power or thrust problem I’m having. I was playing with parameters like Q_M_SPIN_MIN, Q_M_SPIN_ARM, and Q_M_THST_EXPO but as you can see in the video the aircraft takes off really violently, for sure in a VTOL plane with the extra weight it’ll be more stable, but I’ve tried that before and the same happens, I’m not sure what parameter to change, I haven’t been able to move on to other settings like PID tuning because of it. Also, I never feel that I have enough YAW authority, and I think that’s a problem when doing the transitions, and it starts to spin. I would appreciate all the help from this community.

In the video you can see how the throttle never got close to even 30% and it shoots to the sky, also I’m using Q_stabilize

Some time ago I had good results with a 3S battery, but the Idea here is that no matter what battery we use we still have control.

Link to .log and .param

I don’t know if this is the solution but, have you tried calibrating the ESCs individually, connected directly to the Rx to confirm it has learned your system’s end points?

Good luck.

Thanks for the reply, they’re calibrated, but the motors still jump to a high hover thrust.

These are probably reversed:
and this is way too high:
Q_M_THST_HOVER,0.35 - try 0.15 and it will eventually learn a new value if you can get relatively stable hover.
and I think you need to add a bit of dummy payload as it seems very overpowered at this stage.

I’d probably reduce Q_A_ACCEL_P_MAX and Q_A_ACCEL_R_MAX to half their present value, slow things down a bit.

1 Like

Thank you so much! I did change the values and it works a lot better. Here’s a video

Saw your youtube video too, nice :slight_smile:

1 Like