Servers by jDrones

Throttle over sensitive in Stabilize mode


(Filipe Morais) #1

Lately my associated pilot (I usually only configure the drone and operate the GCS) has been complaining that throttle/altitude control is over sensitive in stabilize mode, that is, he is unable to find a “hover spot” (a little less input on the throttle stick makes it start falling and a little more makes it climb somewhat fast). We’ve been having no issues with altitude control in any other modes though.
I can’t be entirely sure now, but I believe this issue arise after upgrading from 3.3.3 to 3.4.2 (using 3.4.4 now).

I would like to improve this behaviour, but I am not entirely sure what parameters could cause this in Stabilize? In “Basic Tuning” I already have the “Climb Sensitivity” setting the minimum (0.5).

I am fairly comfortable with PID tuning and control theory, but I am not sure what are the controllers used in Stabilize mode and which are their parameters

Only thing I can think of is to change the throttle curve on the RC transmitter, but since the behaviour in all other flight modes is considered to be ok I was hoping there was some setting I could change just for Stabilize?

Thanks in advance


(Luís Vale Gonçalves) #2

@ist165351

Lots of things changed between those versions and very specifically how throttle is handled and how TH_MID is automatically calculated (before was a manual process)

Also MOT_PWM_MIN and MAX are now configurable parameters independent of Throttle PWM

There’s no need to mess with Radio Curves (as in don’t do it :slight_smile: )


(Filipe Morais) #3

Thank you for your reply @luisvale. I am aware of TH_MID now being automatically estimated, as well as of the MOT_PWM MIN and MAX parameters. Still, I don’t think they can help me with my issue? I also feel against messing with Radio Curves (thus this post), but I really don’t know what I should change on ardupilot to make throttle response more smooth (in Stabilize)?


(Filipe Morais) #4

Anyone has any other idea besides messing with RC curves?


(Luís Vale Gonçalves) #5

Just do a Auto-Tune. Just had a flight with a extremely overpowered quad and Auto-Tune gave some great results.

After a correctly tuned copter have a go on this

http://ardupilot.org/copter/docs/current-limiting-and-voltage-scaling.html

and this

http://ardupilot.org/copter/docs/motor-thrust-scaling.html


(Francois Gaetan) #6

I had the same problem and I have solved it by setting the value of MOT_THST_EXPO and MOT_THST_HOVER to 0

Hope it helps