Throttle Oscillation? Quad ups and downs

Hi guys,

I recently finished my Pixhawk build. It’s sitting confortably on foam in a QAV400 frame with 1100KV motors, 30A ESC, 3DR telemetry and a GoPro.

Yesterday while running a few test flights, I notice that when i tried to hover in stabilize mode it would move up and down about ~2/3 feet. I tried my best to keep the throttle steady but it would just move up and down on its own. It was kind of like a sideway toiliet bowl oscillation.

This likely has something to do with throttle curve? Can anyone direct me to instructions to fix this so i can maintain more stable hover in stable mode??

ALSO, can i take off in Loiter mode? It doesn’t appear so, everytime i switched to Loiter while on the ground, and tried to apply throttle the motors would not turn.

How about providing tlogs and/or data flash logs to help troubleshoot your issue.

I’ll provide the log files after my next flight. I’ve changed some basic settings in Mission Planner but haven’t had good weather to fly yet.

Until then, any reason why the motors will not spin when arming in Loiter mode? This may be normal but I thought i read we can arm in Loiter or Altitude Hold.

I’ll post newer logs after my next flight.

Here are logs from my last two flights before messing with PIDs.

2014-11-23 15-08-43.log
This flight used a [color=#4080FF]4S 4200 35C battery[/color]

2014-11-23 15-13-49.log (sorry couldn’t upload cause it’s over 5MB)
This flight used a [color=#40BFFF]3S 4400 15C battery[/color]

It was interesting to see how much just a battery swap will impact flying characteristics. 3S IMO flew much better with default settings.

Loiter requires that the throttle is just above 50% before it will take off. Above 50% it climbs and below 50% it falls.

Based on the logs you have a left to right oscillation going on. It seems the copter is over correcting in the roll direction.


Sorry, Loiter mode requires HDOP for GPS to be below 2.0 to arm. Yours was at 2.5 which is too high.

You can however arm in Stabilize mode and then switch to Loiter and takeoff. Again throttle must be above 50%.


Yes, it seems >2 GPS HDOP was the issue for the arming. Once I had HDOP under 2 the quad armed fine and acted as you described with throttle at 50%.

The quad is much more stable now after sliding the basic tuning Roll/Pitch to the left (decreasing values). I also raised the mid Throttle to 600, from 550, with much better response now.

Now i just have to figure out how to “soften” throttle between 45% and 55% and i’ll be good to go. Any tips on how to smooth out the throttle curve through Mission Planner?