Throttle isn't providing enough power


I have a 3DR Quad with APM 2.6 and upgraded my radio/receiver to Taranis FRSKY and X8R RX. I essentially did a rebuild and finally ready to get in the air. First attempt to lift off tipped over and after that was getting beeps approx 1 sec apart when providing power from LIPO. After much fussing around and several pre-arm check fails I went back through all the calibrations. I noticed that the motors were not spinning together at all so I did the ESC calibration twice. Once all this was done I was getting good arming and motors were spinning nicely when armed and performing together. I put the props back on and ready to go!

I put the quad in place, connected battery and armed. Motors did not spin. And when I applied throttle motors spun up but never fast enough to provide lift. Interestingly the motors spun with much more power when I provided pitch or roll with right stick. They sounded normal. But with throttle they were just spinning away but not all that fast. I thought the battery might be low but it all cells were at 4.10. Even so I tried a different battery and redid the radio calibration - same result. Arms, motors don’t spin when armed (even though they did so without the props) and not enough thrust for lift. I suspect I have my throttle messed up somehow but not sure about next step.

Any advice appreciated.


Did you also happen to also upgrade to latest 3.1 code when you did your re-build?

Reason I’m asking is I had the same issue today. Took out a quad I haven’t flown in awhile - I flew it last summer successfully on what was probably 3.0 code(don’t recall now). Flashed latest 3.1 code, ran through full calibration and it barely gets above arming speed at full throttle.

Now, I can hold it in my hand and force it to yaw or pitch and sure enough it will fight me to level out. I tried a recalibration of all esc using the built in functionality in ardu and after the levels are set I can bring it up to full speed - so I know the ESCs are working and the ardu code is able to spin them at full throttle.

Running SimonK on hobbyking blue series ESC on an APM 2.5 board.

Sorry to pile onto your thread here, I thought if two people reported it maybe it would get some additional thought from the forum wizards :wink:

Reporting back, I was able to solve my issue by doing an EEPROM erase and flashing 3.1.5 fresh.

Figured there had to be a setting somewhere that was causing trouble and I was right.

Fred, can you give that a try?

I have the exact same thing going on with my first build. I know there is plenty of power because when I switch to RTL the quad tries to climb to 125 feet. How do you erase the EEPROM?

Update. I was not able to figure out how to do an EEPROM erase, but I did load one of the older versions and then reload to 3.1.5. Now when I arm in stabilize and advance throttle the quad has plenty of power.