Throttle Fail Safe - can't arm

3DR Quad
ArduCopter V3.1.5
3DR GPS/Compass Module
FS-TH9X Fly Sky FS-TM002 Radio/ Fly Sky FS-R9B receiver
3DR PPM Encoder
1.3.9 Mission Planner

When I power on the Quad, the Pixhawk’s Main LED Flashes yellow slowly, and I can’t arm. When I am connected over MavLink with the 3DR Radio I can see the “PreArm: Check FS_THR_VALUE” Message on the Flight Data Screen.

Attempted Fix:
First I made sure the RC was connected by going to the radio calibration screen and watching the inputs change when I move my RC sticks.
Second, I recorded the minimum throttle PwM value when the throttle was at MIN, and when the RC was powered off. RC off 900 - Min throttle 1056. I set the throttle fail save value to 920, 950, and 1040.
I also tried turning off the fail safe. Doing this didn’t let me arm, but I didn’t see the thr_FS message on the flight screen.

I read that the flashing yellow LED on the Pixhawk indicates a radio check failure. I don’t understand this, because I can go to the status screen and see the radio inputs change while the LED is flashing yellow.

BTW, everything was working until I loaded and wrote new parameters to the Quad while trying to fix a Yaw problem. I’ve tried re-writing the old parameters. I also did a new radio calibration after that when I discovered the new problem.

Any suggestions?


I don’t know what the problem was, but it’s fixed now.
I reloaded the firm ware, and redid all the calibrations. It’s working great now. I don’t know what the problem was. I’m going to leave this open for a bit more to see if anyone has any thoughts as to what the problem was.


No Replys as of yet, so I am closing out this post. What I have learned from this and with some friends’ copter problems (multiple crazy problems), is that most things can be solved by Reloading the firmware, erasing the EEprom, and doing a complete re-calibration. (make sure to erase the EEprom) If everything works well, save the new parameter list.