Servers by jDrones

Throttle don't stop until touch the ground


(Lbarreiro) #1

Hi,

In FBWA when approaching to land I cut the throttle but the motor keep running in idle until touched the ground.
Right after the landing and in the same mode (FBWA) I apply throttle and then cut and the motor stop.
Any one can help with this.
The plane is a Skywalker X8 and I’m running the latest firmware in a Pixhawk 2 Cube with folding prop.
Thanks


(Hunt0r) #2

When I cut the throttle, the airflow continues to spin the propeller, not the motor. Of course on landing, the airflow stops and thus the propeller stops. I think this is called “windmilling”. Could you be seeing this phenomenon?


(Lbarreiro) #3

Thanks for the quick replay.

No, I have folding propellers so the wind will fold them if the motor stop.


(Hunt0r) #4

Ah okay. Would you attach a dataflash (.bin) log demonstrating the problem?


(Lbarreiro) #5

the link for the dataflah file is

https://drive.google.com/file/d/18le0M2nVMbcB0AAfu4bi_6owa498tmrt/view?usp=sharing

Thanks for your help


(Hunt0r) #6

I am looking at your log, would you help me spot the problem?

I have zoomed in on what appears to be your final landing, which was done in FBWA mode. I see that the Channel 3 Input and Channel 3 Output (presumably the throttle input and output) match except for an offset. Your THR_FS_VALUE (throttle failsafe value) is set to 990, and the input stays above 1100 so that shouldn’t be a problem.

c3

alt

Based on this, the motor should have been cut off during your final landing, between 1965 and 2000 [sec] of the flight, as shown in the logs. Is this not what you observed?


(Lbarreiro) #7

Thanks again for your quick help,

As you can see in the first picture, I have tried a first trial to land and observe if the motor stop, and it kept running so I go around and then land with the throttle cut but the motor still running (in the timing that you tell)

The strangest thing is that in the beginning of tha flight I have tested and all work just fine - I throttle up the motor start and then throttle cut and the motor start


(Lbarreiro) #8

In the next flight the same behavior, with the same values as you showed in your graf.

I also have the bin file if you need that


(Hunt0r) #9

My graphs show that when you command zero-throttle (PWM = 1100 for C3 input) the Channel 3 output consistently goes to a value of 1000. This is true at the beginning of your flight log (not on these graphs) and also here at the end.

This tells me that ArduPlane is behaving as expected, and is not the source of your problem.

I just had an idea! I have a plane with an “intellegent” ESC (From Castle Creations, I think) which had a strange issue: the Castle ESC calibrates “zero throttle” to be whatever PWM value is seen at power-on. (Let’s say this was 1100, for example.) However, in a particular situation (details aren’t important) it was possible for me to send a lower value via C3 (say 950, for example) for a short period of time. This caused my “intelligent” ESC to re-calibrate the zero-point of the throttle as this lowest value, The unwanted outcome was that the original value (1100, by example) was NO LONGER a zero-throttle command! (It was something like 5% throttle, making turning off the motor impossible without re-using the special 950 command.)

Could something like this be the source of your problem?


(Dave) #10

Does your ESC support braking?


(Lbarreiro) #11

I have a YEP ESC, and the break in in hard as the programming card.

I agree with you Hunt0r, I will change de ESQ and report back

Thanks again


(Lbarreiro) #12

Problem solved

Change the ESC and now work fine

Thanks