Servers by jDrones

Throttle chatter/spiking when in auto throttle modes

Hey folks,

I’ve been working through the set up of a Bixler 3. I’ve performed AUTOTUNE several times now, the plane flies great in FBWA. When I switch to auto throttle modes like FBWB & RTL, I am noticing high frequency chatter/pulsing throttle around ~2.5Hz (quite audible and you can obviously see it in the flight telemetry). I have tried increasing TECS_THR_DAMP, TECS_TIME_CONST and I’ve drastically reduced THR_SLEWRATE down to (15%) and these changes seem to improve things a little, but the chatter/pulsing are still there.

I have an airspeed sensor that is measuring but not being used for control (ARSPD_USE=0). I have not re-calibrated the ESC, I have been flying this Bix3 for years with this particular ESC and it has been working fine out of the box. Not sure if this could be a contributing factor to my throttle issue.
I flashed the pixhawk firmware about 2 weeks ago so I’m pretty sure I’m running 4.0.6 (I’m still a newbie to this, this is my first post!). Any help would be greatly appreciated!

An update

This post helped me: How do I reduce throttle "pulsing" in auto modes?

When I turned off THROTTLE_NUDGE it seems to have fixed the issue. Does anyone else have throttle chatter/pulsing when using THROTTLE_NUDGE?

I just noticed today when in FBWB with the throttle above 50% I’m getting the oscillations. They disappear when I switched to Auto, or if I moved the throttle down below 50. I have throttle nudge on, but I normally turn it off. This is a new build and I haven’t done the TECS tune yet. Everything else is flying so well I wasn’t sure I was going to bother… and then tonight I looked at the logs.

Servers by jDrones