This should be interesting

That button on the GPS is the safety-switch.
I have same problem with servos going to extreme position when pressing it (kill all PWM outputs).

From what I read, my guess is that your pixhawk is somehow switching between Stabilize and Loiter or the safety-switch disarm itself after some time.

Pitt,
The part about the safety switch and servos going to extreme when it disarms is spot on to what’s happening. Ive watched the “radio calibration” tab for awhile and according to MP no channel gets a random pwm when it disarms so i dunno?
As to switching to loiter and back to stabilize, when i do a radio calibration, i can hear it beep as its changing flight modes, also a few times when the servos stopped and the red light on the gps started flashing vs steady red around the bitton, i flipped the switch to see if it was still responding to radio commands. It was, i could hear it beep and therefore i went into RC cal and saw the bars moving, so i knew it wasent an RC issue, something else. :confused:
Thanks,
Tim

It is very possible switching to loiter in the logs, and back again was a commanded thing after the system stopped responding to cyclic, rudder, pitch and collective inputs. Looking back im quite certain i was just flipping anything I could to excite a response of some sort after the swash locked up.
Tim

-one more thing i noticed while on the bench, when i give cyclic commands and “get further out” on the sticks, i see the tail blades moving as well. Is this normal behavior?
I am 100% certain there is absolutely no mixing going on in my radio, verified by watching the output screen on my Horus while moving the sticks, its just in a simple AETR mode, no heli specific setups whatsoever.
Tim

Ah, OK. So that has been incorporated into the GPS unit - that’s kind of a neat idea. Now it makes sense why the servos acted as Tim described by pushing the button.

I don’t use a safety switch on my heli’s and have that disabled.

With traditional helicopter, Tim, the servos are active without the FC armed in Stabilize or Acro flight modes. And the software has a servo exercise function at power-up as well. This is nice features to be able to do your pre-flight checks and verify correct servo function prior to engine start. The safety switch, some people like it, some don’t, I’m one of the ones that don’t. With some vehicles where you could get an accidental motor start by arming it’s probably a nice thing. With heli’s where you may be starting a combusion engine, or with electric have a separate switch that starts the motor, and then want to do pre-flight checks of servo’s etc., it’s kind of a hassle IMO. That’s a matter of personal preference and pre-flight procedure.

Let’s look around this button on GPS.

This is step of my Pixhawk 2.1 booting up, do you find yours different?

  1. Turn on radio
  2. Plug battery into power module (Pixhawk now powered)
    -Safety switch flashing red (4 flashes - pause - repeat)
    -Reciever is now working
  3. Power servos (if using separate batt)
    -Servos shouldn’t move or resist at all.
    -ESC beeping with no-signal code
  4. Press (hold down for ~2sec) safety-switch
    -LED turns solid red.
    -Servos now functioning
    -ESC start-up complete but will not respond to Throttle stick because it is in Disarmed state.

It will remain in this state as long as battery lasts.

Now from what you explained, safety-switch somehow went back to flashing on its own?
Try again with ESC and motor (remove pinion for safety) and see if it beeps when servos stop responding.

I just ordered HERE GPS today and haven’t touched loiter so I’m not sure.

Pitt,
I am operating a little differently, i’ll try to explain. A’s I’m on the bench, I’ve omitted plugging in the power module as the unit powers itself off the USB. It’'s on my workstation PC, which by design has higher amp rated USB ports, so I am not worried about it drawing too much in the least.
-I plug in my 2S that powers the receiver and servo rail.
-then I plug in USB to power up the Pixhawk 2.1 unit.
-It goes through the tones while the red/blue led’s on the sides of the Here flash, the button and it’s led is flashing with a red circle.
-Servos are moving right from the moment the Pixhawk boots up
-the led around the switch goes from flashing to solid by itself, doesent require me pushing it.
-as for the ESC, I haven’t incorporated that yet as i’m waiting for a 200 AMP sensor to integrate as I’m on 12s.

Tim

-so I went into the full parameter list and set BRD_SAFETYENABLE to 0, when it boots it does go solid red after the tones, I have control of trhe servos for a few seconds and then the swash locked hard left and lost control of the servos and the led on the here switch was back to flashing red.

-Another attempt was similar, except the swash did not lock up to the left, I just lost control of the servos and the led on the Here was flashing again.

Tim

That really looks like safety-switch is the cause.

Do you still have the safety-switch included with Pixhawk 2.1?
I think it’s worth a try now.

I do still have the included switch. As I am a newbie with this system though, i’m not seeing how I could include it with the Here GPS? Wouldn’t setting BRD_SAFETYENABLE to 0 take that out of the equation?
Tim

2017-05-02 10-36-24.bin (588 KB)
timbaconheli 3.5 parameters.param (13.6 KB)

That log and parameter file is from a recent test, I plugged in my receiver & servos, plugged in the power module to start up the pixhawk, it booted and played the tones, the led on the here was solid red until the servos locked up and it started flashing. Hopefully there is a clue in there? I’ve leafed through the logs myself, but alas, I have no idea of what i’m looking for.
-I’m going to watch Rob’s video and go step by step and see where that gets me.
Tim

Well, since you lose control of servos when LED is flashing, safety-switch is probably still doing its job.

And you need to unplug GPS to use included switch.
This is only to check whether it is safety-switch side or Pixhawk side causing your problem, just swap plug for a minute.

Pitt,
Okay, that makes sence. Do i have to change a parameter after i remove the GPS so it doesen’t just fault out?
Tim

Don’t think you need to change any.
It might just tell you GPS is not working or something.

ArduCopter will fly fine without GPS in certain flight modes.

I was looking at your log. I might not be as good as others here at this but just trying.

What I see is a 41 seconds long logging,
you started swirling stick at about 20 sec mark.
The board lost signal from receiver 4 seconds before end of file.

At which point did servos stop responding?

Pitt,
I took the GPS out of the equation and guess what, worked as it should. I just followed Robs setup video and set the heli up without issue. Going to have to look into whats goin on there I guess.
Tim

Tim, I noticed in the last log you posted it was spitting messages that it had detected the GPS multiple times. And then the file just ended like the controller either rebooted or the safety switch disabled it and it quit logging. I don’t know which it was.

Double check your wiring and pinout to the GPS unit. It seems to me you made a longer cable for it? I did not realize they have a safety switch incorporated into that thing for the Pixhawk2.1.

Chris,
That’s exactly what i’m going to do, check the wiring to the Here module. When I made the cable up I did one wire at a time as to eliminate issues, that being said I have no benchmark as to whether the GPS was wired correctly out of the box. :confused:
Either way, i’m much happier now that the unit seems to be acting how one would think it should. The setup was not bad at all, not much different than a typical FBL as far as setting ranges, centers and cyclic ring. I’m sure the PID is going to take some time, but either way I at least feel like I am getting somewhere finally.
Tim

Well, that’s what I had suggested back in post #71. I received a M8N with the pinout reversed Ground pin was right, the red/yellow/green were reversed. Since you got compass and safety switch in there, your unit must have 8 wires. Isn’t there documentation on the Pixhawk2.1 on pinouts?