The aircraft enters Qland mode when it is flying a mission in auto mode


Hello everybody

I recently had a problem when I was running a mission in auto mode.
The area has an abrupt relief and the mission is planned using a height of 120m above the ground.
Using altitude over the “terrain” in mission planner.

To get to the first waypoint, the plane must be below the height of the house to reach 120m above the ground.

I am flying with a VTOL, the takeoff in copter mode and transition to plane mode, is done without problems and when the plane goes to the first waypoint and when the plane reaches a height of less than 29m in “plane mode” it changes to “QLand mode” and stops executing the mission.

I then have to take the plane in cruise mode to prevent the plane from landing on the ground and bring it back home for land it.

I have already flown with another plane (not vtol) in similar conditions and the plane has even flown at a height of -200m above the height of my house but at 120m above the ground.

I looked at the full parameters list for one parameter saying that when the plane flies in auto mode and descends to a height of less than 29 m, above house height, it enters in “Qland mode”.
Unfortunately, I am not able to find any parameter about this.

Can anyone help me on this?