TF mini T01 LIDAR help. How to troubleshoot

Im attempting to connect TF mini T01. In running the latest version of Ardu planner and the latest firmware. Ive wired it according to the documentation on telem2.
Ive setup the parameters according to the documentation. setting the parameters outlined there.
I get nothing but Bad LIDAR Health. Ive tried removing power and ground from serial and powering it from an external BEC before boot but that didnt help. Can someone help me or point out how I can begin to troubleshoot this?Icant find anything out beyond the prompt saying BAD LIADR and seeing the sonar range not displaying range. it seems like everything I try to do with ardu turns into a knife fight in the dark.

I find one setting from the Benewake instructions that didnt translate to this version of Rover. RNG_FND_GAIN. the instructions say to set this to 0.8 is their a setting in the current version of rover that I should be setting for this?

Things Ive tried that havent helped.

  1. removed power and ground from serial and powered with BEC. No result
  2. Changed RNGFND1_Type from 8 (benewake manual setting ) to 20 setting recommended in

changed from serial 2 (benewake manual setting ) to serial 4

anyone got any idea on what else I can try before I try returning this LIDAR.
can anyone suggest a lidar that will work with rover that has available settings that work ?