Testing PX4Flow on a Pixhawk

I have a PX4FLOW which I am playing around with. I have updated the firmware as below, and tested, focus the image. All very good. AS BELOW
Pixhawk Setup

Note: Applies to all PX4 FMU versions, including all versions of Pixhawk.

  1. Update the firmware on PX4Flow using QGroundControl (in the top left menu, click on CONFIG, then on Firmware Upgrade)
  2. Connect PX4Flow I2C to the Pixhawk I2C
    [color=#0040BF]The module will be detected on boot, flow data should be coming through if the autopilot is connected via USB. Flow data is not transmitted via wireless[/color].

I am having problems testing it on a Pixhawk. I setup optflow in the CLI logs on mission planner, but when I try to test it just returns the word optflow, Running the log file on a dummy flight, the log does not show the Optflow at all, even it is listed as being logged. Tried in firmware ver 3.2.1 and ver 3.1.5.

Can anybody comment on this

Hi. Your on the bleeding edge using the PX4Flow sensors which is great. They are functional in the very latest Copter code but in Plane and Rover they only log at this stage and don’t provide any input into the flight control. I mention this as I’m not sure what vehicle code you have on your pixhawk.
I assume you have read through this page?
plane.ardupilot.com/wiki/common- … -overview/
If you still have trouble post again and I will see what I can do to help.
Thanks, Grant.

Hi Pmorph (Grant)
Mt pixhawk is on a Trad 450 Heli. Running 3.2 (I’ve also tried it on 3.15). I’m getting no response in the status on Mission Planner, and as I said I cannot get the OF in the log to show, even though it is showing in logs in the terminal page. It is wired in on the Pixhawk IC2 socket. I’ve retested the PX4flow Image and it’s working fine.
I’m just want to check that the Pixhawk can see it, so it’s all ready for the firmware to run it.



Make sure you have FLOW_ENABLE set to 1

To check if your board can actually read the sensor, you need to log in to the nsh terminal using a debug cable as shown here:

dev.ardupilot.com/wiki/apmpilot_ … g-the-nsh/

Note, it is easier to access the nsh prompt if you remove the SD card first.

Then at the nsh prompt type

If it returns <px4flow: driver not running> then enter check the message returned and reenter to check the status.

If that doesn’t start it, then you have a hardware problem.

One of my flow sensors has an issue whereby I have to power the pixhawk via USB before connecting battery, or else the sensor is not detected by the Pixhawk on startup.


Hi Paul
Thank you for your help, so far I have made the cable up, and using a USB to TTL board.
There is no + cable to the pixhawk plug, is that correct.
I have tried starting the pixhawk on the battery, then removing the SD card. plugging in the USB
on the made up unit.
I then started Mission planner and connect the unit with the correct com port. where it states that the com port is opened. Not getting a prompt at all.
I can’t get any further than that, tried hitting the enter key, Arming and running the heli, (with the motor disconnected) What am I doing wrong?


Hi again,
I have got the ‘nsh’ prompt working OK now, after starting the px4flow, and then doing a test run.
All appears to be working OK, and it says PASS at the bottom of the test output.
I will now try it on a dummy flight to see if it records on a log.
Thanks again for your help.