Servers by jDrones

Testers needed for in-flight compass learning


(Matt) #41

If you’d like to test it, my lawn will need to be cut again in about 2 hours with all the rain we’ve had the last 3 months :slight_smile:


(Kenny Trussell) #42

Depending on where you are we might have a deal! Let’s see, maybe I would charge about $1.00 per mile for travel???


(Kenny Trussell) #43

@tridge I will send logs later, but I had to stop to say WOW! This is the best thing ever for a large rover. Worked flawlessly. And having the compass right has made pivot turns do what they are supposed to do. I have never had this tight of a pivot turn I don’t think. This is going to make my life so much easier. Thanks a million!


(Marco Robustini) #44

This is the video that shows the new feature.
I noticed that the audio tone is too low, would like at higher frequencies or is not audible, it should be similar to that of changing flight modes.
In addition, the LEDs status don’t change colors, i see only two fast flash, so there is no visual feedback of the end and beginning of the procedure if the LED is not visible in all the position.
I would put the flashing yellow LED during the procedure (RC with function 62 at high state), and flashing green when it finishes until the RC channel is brought to a minimum value, or just increase the flashing time.
During the calibration the “Bad Compass Health” it should be removed from Mavlink message.
Here in only 5 seconds all the compass are calibrated.


(Marco Robustini) #45

As the arming check doesn’t allow arming if the compasses are not calibrated it would also be useful if the RC channel with function 62 could “emulate an arming check at 0” when it is in the trim position (in the middle), so you can arm with un-calibrated compasses without having to put Arming Check to 0.
So at the lower state “no in-flight calibration”, at the middle “allow arming for the calibration” and high “calibration enabled”, or something similar.


(wkf94025) #46

Great enhancement Tridge. Sorry, no time to fly recently, and stoked by what I read about others’ quick success here. You just eliminated one of the more maddening parts of a new bring-up in MP.

Kelly


(tridge) #47

great, glad it worked!


(Kenny Trussell) #48

EDIT: On second insert into PC, logs were there - just an SD glitch I guess. You should be able to get to the log here: https://www.dropbox.com/s/w45f93r96bp26ve/00000105.BIN?dl=0


(tridge) #49

thanks. The calibration result looks good for the X and Y axes (which are the most important), but the Z axis has an odd oscillation:


The oscillation doesn’t seem to correlate well with throttle. Is there something else on the mower that could be changing the vertical magnetic field?
It shouldn’t matter a lot for yaw as that is dominated by X and Y, but it is curious.
Cheers, Tridge


(tridge) #50

also, slightly odd that your only GPS is setup as the 2nd GPS. Harmless, but made log analysis a bit harder


(Kenny Trussell) #51

I need to move the cable to the GPS plug on the Pixhawk, I guess. I had another GPS there at one time, so my Ublox C94-M8P RTK GPS got plugged into another serial port. I just never moved it.

I believe the Z oscillation could be just the bouncing of the mower over the terrain. I was running it in a hay field at my house. It is pretty smooth, but not asphalt smooth!

Exciting revelation (for me, at least):
The ability to calibrate, which you gave us, showed me something very interesting. I am getting a 20 degree offset when I run the mower blades! I did not expect this since the compass is about 3 feet above the mower deck. I captured my Mission Planner screen and annotated it to show this. Hopefully this will help someone else. I re-calibrated with the blades running.

The video is here: https://youtu.be/gBn3Eygo88o


(Markus Greinwald) #52

Hi Tridge,
I also like to test it.
I need a version for the pixhwak 2.4.8.
At the moment I use the version “ArduPlane V3.9.2” fmuv2 ChibiOS.
Cheers Markus


(tridge) #53

@master-of-desaster-8, the Pixhawk1 builds linked above should work for you
Cheers, Tridge


(Randy Bachtell) #54

I came to the party late but I just tested a quad(cube black) and a 1 meter hex(cube black, zubax UAVCAN). Both seemed to perform very well with a very rapid calibration. Both vehicles were very stable to begin with but the hex in particular is very awkward to dance with so this looks to be a huge improvement in compass calibration process. I was not comfortable using crazy offsets on the big one but as soon as I have time i will do it on the quad and compare final results. Thanks for all the good work. Cheers RB



(Matt) #55

I bet I know why! Nothing at all to do with the mower deck or blades. I assume this machine has an electric PTO clutch? The PTO clutch is giant electromagnet. Perhaps you can move the compass further away from the PTO clutch? Although given the design most ZTRs and how intense that interference is, you may never get it far enough away from that.


(Dave) #56

The Pixcacer version didn’t work for me. It 's either loss of basic RC input or all channels are randomly jumping around depending on each boot.Flash back to Beta and all good.


(tridge) #57

@dkemxr interesting, what receiver are you using? What transmitter? How many channels in the RC link?


(Kenny Trussell) #58

That is an interesting theory. Eventually, I will experiment with the compass location and see if I can determine. Thanks for the insight.


(Markus Greinwald) #59

Hello Tridge,
I have installed the version 2 (…/test2; RCn_OPTION=62) on a Pixhawk 1.
The installation was without problems and at the weekend I will test it on the airfield.

Now I have ordered a Pixhawk 4. Could You please provide a version 2 for me?
It should be fmuv5.
I also could create the software if You tell me whitch brand or tag I have to choose.

Cheers, Markus


(Dave) #60

A Frsky XSR with an X9D 16 channels on Sbus.