Terrain not working on CubeBlack

I am trying to use terrain following with CubeBlacks, but for some reason the feature doesn´t seem to work at all. I set TERRAIN_ENABLE to 1, but after connecting to MissionPlanner, in the status tab ter_load is 0, ter_pend is >200 and the starnge thing is, that ter_space is also 0 (and this doesn´t change when using different TERRAIN_SPACING values).

I also have a Pixhawk 4 and there it works as expected with the same GCS, so the issue must be with the cube blacks (I have tried more than 1).

Is the F4 processor too slow for terrain following? Could it make a difference if I disable some other features? What could I possibly disable?

I had this same problem about a month ago. Here’s the post where I discussed it and the solution I came up with. #54967

I did a bug report on github but so far no one has responded.

I hope this can help you.

Oh, thanks, this fixed the issue!

edit. I can´t even create the folder using mavftp. I have to physically remove the card and create it on a PC…

1 Like