Terrain following using lidar in auto mode

Hello everyone,
I am trying to enable terrain following in autonomous mode using TF 02 Lidar.
I have configured lidar on telem2 port at 115200 baudrate and i am receiving distance in mission plannner and its working in loiter mode. I tried enabling terrain following in auto mode but could not get it working.

My setting are:

  1. rangefinder type = 9
  2. using Serial 2 with 115200 baudrate
  3. rangefinder orientation = 25 (downward)
  4. Terrain enable = 0
  5. Terrain follow = 0
  6. Rangefinder max_distance = 10m
  7. Rangefinder min_distance = 5cm
  8. Ground clearance = 20cm
    Now, I am confused if i should enable Terrain enable = 1 as it is stated in ardupilot site that it is used for getting terrain data using google maps.
    While switching from loiter to auto i am constantly getting 2 errors: 1) Terrain Data missing
    2) Bad Lidar Health
1 Like

I have encountered this in the past due to ‘Terrain’ being the selected height method in the Mission Planning screen.

so were you able to solve the problem. What are the setting you used.

I simply chose one of the other 2 selections and it solved the ‘Terrain Data Missing’ error.

The ‘Bad Lidar Health’ was simply getting the readings to coincide with the parameters, especially the minimum distance, which generates that message when trying to arm if incorrect.