Terrain Following Not working on Setting OA_TYPE to 1


I was trying terrain following with my Quadcopter using TF03 lidar rangefinder using as Altimeter and also for Obstacle avoidance (in forward).

I created a Mission using mission planner setting terrain Frame and took several flights in auto mode.

What I observed is on setting OA_TYPE = 0 (i.e disable terrain following in auto mode). The drone is able to follow terrain using down facing rangefinder as source for terrain.

But on setting OA_TYPE = 1 ( obstacle avoidance using bendyruler ). The drone was not following terrain.

Before switch to auto_mode we take off in loiter and stop the drone at ~6m of height. But the whole mission was made at 4m of height. Now, If OA_TYPE = 1, the drone does not comes to its 4m height rather it do the auto mission at the same 6m height.

It appears that the height is freeze and is not getting updated.

@rmackay9 @peterbarker I think this is a bug.

Yes, that’s right. The issue is here: https://github.com/ArduPilot/ardupilot/issues/16479

Hi @rmackay9

Has the issue been fixed?

I believe it has been fixed by Randy. It should be there in Copter Beta release. It would be great if you could test it out!
The only problem is that we have some problems with BendyRuler itself in the new Beta release, which should be fixed soon. Please stay tuned

@rishabsingh3003 I will test the beta version tomorrow.
Even with the BendyRuler disabled I’m having problems accompany the ground using the TF02 Pro. Below are the results obtained, with the Terrain option enabled, the drone accompany the ground according to the terrain information obtained from the network and not from the TF02 Pro.

Here is my log: https://drive.google.com/file/d/1zmAu-O42L5dyfKF1-apZoU5egyaMwflp/view?usp=sharing

I installed the beta version on my Cuav V5+ but it doesn’t recognize my serial gps, only the can. I can’t test.