Terrain Follow Dolphin Flying

Hey, We’re having an issue with terrain following in AUTO when using a rangefinder. Issue is once it starts the part of the mission where the aircraft is using the rangefinder it starts oscillating and over and undershooting its desired altitude. For example when trying to hold at 3m it dips down to 2.8m then overshoots up to 3.8m and continues like that. We’ve tried changing the RNGFND_FILT param and had no luck with it correcting the issue and we’re stumped. The aircraft we’re flying is an Inspired Flight IF1200A. I’ve attached a log file from one of the flights with the issue along with a graph with the oscillations circled. Let me know if any other information is needed. Any help is appreciated. Thank you.

Not related to the issue described, but you can safely drop the number of harmonics filtered, and disable the in-flight FFT


I could see your problem but couldnt find an actual fault or anything to change with the rangefinder and that flight.
You are on firmware version 4.3.0 and there have been improvements to rangefinders in 4.3.3 (or there abouts) and I believe more has been done since then too.
Latest stable is 4.4.3 so I would definitely upgrade to that and retest.

EDIT: since this firmware is branded as IF1200A you might want to check in with Inspired Flight to see if they’ve got a tested later version of firmware, or ask them if it is OK to use the standard unaltered Arducopter firmware.

There some extra rangefinder-related parameters too, but they are mostly within the EK3 section so we wont mess with those unless absolutely necessary.

Parameters will automatically convert for any that have changed between firmware versions. That .bin log contains all your current parameters anyway, as a backup.

1 Like