Terabee Evo 60m rangefinder not working with Cube Orange flight controller


I am not receiving output from the Terabee lidar when it is connected to the Cube Orange flight controller(no sonnarrange reading on Mission Planner). I tried it on a Pixhawk and it worked just fine. Does anyone know how to solve this issue?


we’ve had the same problem with a Teraranger EVO 40m.
We’ve contacted the company technical support and they replied that they had problems with Pixhawk Orange. If you check the compatibility board, Cube Orange is not present but only the first Cube (Black).
After my request they added “NOTE: Pixhawk Cube Orange does not allow the use of our single sensor Evo Mini, 3m, 15m, 40m and 60m”.
We have another drone with Cube orange and Terabee tower that is working correctly. It seems a firmware problem related to the I2C communication of the single sensor.


Have there been any updates on this issue? I’ve ordered a EVO 60m myself and am hoping it can be resolved

CUAV X7+ works great with EVO 60m.

I was more interested in the Pixhawk Cube orange, since that is the platform I am using