Servers by jDrones

Telemetry will not connect ” no heartbeat received” HELPPPPP!

so I got them to read each other finally but when I go to connect them together, it still says no heartbeats received , you know why that may be ? or what I can possibly do next ?

I have version 1.3.74 of mission planner and I’m using ardurover on pixhawk 2.4.8
and I’m using the v2 915 MHz telemetry radio

can someone please help, I’m on a deadline ,
thank you!IMG_7527

When ever I encountered that issue it was because the Air module was connected wrong or the netid was wrong. Looks right on your config. Also I ran into this because I was using the micro telemetry units and not the normal ones. I really had issues with the micro’s.

Now I don’t use them at all. I use the telemetry that comes with my receiver. But that doesn’t help you lol

You could try updating both radios to V2.0. They are V2’s so USB on each right? That makes it easy. Just keep in mind that V1.9 and V2.0 are not compatible so if you have other Air side radios they will all have to be updated. If it all goes sideways you can always flash them back to V1.9.

Before that-You do have Rx>Tx Tx>Rx on the Air radio right?

Hey Dave, yes they both do have usb port for each , how do update the radios ?, is it by dong the "upload firmware " on setup tab for the sik radios ?

And answer your question about the “Rx>Tx Tx>RX” , i am not totally sure , I used the connection wire that came with the radios so i am assuming that it is connected that way, maybe if you can explain or show what that connection is can give you a definite answer

Use the “Upload Firmware Local” button. Connect each one and do this. I’m not sure if it will fix your problem but if you don’t have too many radios it’s a good idea.

So it’s a cabe that came with the units with a connector for your flight controller? Which Flight Controller? It’s probably OK, my comment was if you had made the cable, sometimes it’s easy to reverse these.

yeah I just tried it and it didn’t work,
question, is it normal for the both radios to have to have be recognized as different “COM” ? like one is com 4 and when i connect the other one is say Com 5

Also I’m using the 2.4.8 , I’m using the cable that came with the radio i ordered the v2 radio after i couldn’t get the v1 to work and heard the v2 was much easer to get to work

Com port is assigned it doesn’t matter. Post your parameter file.

param fle 1.param (16.1 KB)

What Flight Controller and what port is it connected to?

PX4 2.4.8 and its connected to Telemetry 2 , on my laptop it says COM port 4

I’m not sure why this is not at default:
SERIAL_PASS2,2 Try setting it to disable (-1) which is default.
And set Serial2_protocol to 2

Reboot after making changes.

I tried that, it still doing the same thing

Almost out of ideas. I must have 10 of those radios and they just work. Got a link to where you purchased it? Got a close up photo of the connection to the Pixhawk?

lol yeah me too, but I def appreciate all your help!

https://www.amazon.com/gp/product/B081RMGJYX/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

Last try. I can’t tell from the photo quality so pin this out yourself.

Does this:

Match this (ignore RTS/CTS):

Is this plugged in backwards? Keeping in mind you need 5V,Rx,Tx and Gnd

your a life saver lol yeah I had to flip it around and it connected right away
Thank you !

Servers by jDrones