Telemetry Via CRSF

Hi all

I have Orange Cube Plus
Iam trying to connect TBS CROSSFIRE Nano RX via Telemetry.
I have Set Serial_1 = 23
RCIN and all the other baud rate( tried 57 and 115) -Bit @ 8.

Briefly I have followed every step in the Ardupilot.
I am using Radiomaster TX16s MKII 4IN1.
Yet its not working
Any ideas please.

Is the RX bound and on the same firmware revision? What TX module are you using in the TX16S?

Double check that you have the TX/RX wires crossed (TX<>RX and RX<>TX)

What light is showing on the RX when you power it up? Red, or green, solid or flashing?

Hi and thanks for your prompt response.

I have TBS Mini (TX) updated to the last version

  • Cossfire nano RX.
    I did the wiring as cross over.
    The binding is done, i can see the Tx RX and wifi on the Radiomaster screen and control them normally.


Bythe way

I tested the Tx16s and the TBS TX and RX on Betaflight and worked fine on a speedybee FC.

Its just the Orange cube + that is not working.

What do you have the RX output set to? Ideally Channel 1 and 2 to CRSF. Then those wires should be connected to the Serial port, not the RCIN.

Also make sure that you only have one serial port set to 23.

I done the settings on Serial_1 = 23

Check SERIAL 5 isn’t set to 23. Some of them default to that.

Are you connected to the Telem 1 port, or the RCIN?

Cable connected to Telem1 on pixhawk to Rx nano


Hi Allister.
Thanks for the info. I will test and update you.

Hi. Hope you doing well.
I have tried RC opt. 288. Yet not connecting.
Any other suggestions plz

Maybe just clarify something for me, are you getting the RC link when you check the mission planner RC calibration page? ie: do the green bars move with the sticks? Or is the issue you don’t have telemetry such as Yaapu?

No. Am not getting that at all.

Even Yapuu am getting no Data there.

Okay, let’s sort the connection first.

  • Make sure you have channel 1 & 2 on the RX set to CRSF. (TBS Agent)
  • Double check the wiring.
  • Post a picture of the RX and the Cube wired together.
  • Post the param file for the build.
  • Confirm when you’re testing the RX has a solid green light.


I do apologise for not getti g back to you with a huge thank you.
I got stuck at work and shall test all soon. Will uodate you.

Kind regards