Servers by jDrones

Telemetry radio link dropped suddenly during tracker SITL operation

During SITL testing of tracker (yawing and pitching), solid green LED of telem radio turns blinking, followed by short beep from tracker controller (Pixhack) with solid green LED starting to blink (meaning disarm ?). This never happen before, and I am very clear and conscious that I did not change any values in the controller just before this happened. For the setting in the telem, I have not touched them for years. This drop started to happen all of a sudden and repeat in every SITL testing thereafter. I changed the telem module setting according to someone who shared his setting, but did not solve the problem.

Have done following :–

  1. checked voltage across the output pins of controller and found to be 5V from a 5V/3A UBEC. Lipo 3-cell battery supplying to UBEC is fully charged.
  2. Found out the UBEC became hot about 20-30 seconds after tracker started to operate (temp readout raised to around 30 deg from initial 15 deg). Thought to be current reduced from UBEC output at higher temp, but subsequent cooling using a fan did not make any difference. Module link still dropped even before UBEC temp increased to 20 deg, 5 seconds after operation.
  3. An ammeter reading indicated the current draw during tracker operation was around 300mA, probably higher while pitching and yawing, but should be much below 3A, the limit of UBEC.
  4. Have tried running SITL in 2 different laptops, one with Windows 7, and the other Windows10 with the same result.
  5. Have also tried another pair of telem radio with different Net ID. Made no difference.

Attached are the links to photos of the tracker, and the param of the controller.

A video showing the drop in telem link with sound of controller disarm (at 10 seconds) is also attached.

Can anyone help to solve this problem, or any clue ?


https://drive.google.com/file/d/1HkTeZY2cZPgG4u1dgBvkUuW7k6nbH-EN/view?usp=sharingParam__pitching works.param (8.4 KB)
https://drive.google.com/file/d/19QocGca6jTSlhjPJb5kKM_YlzW1yUDef/view?usp=sharing

Thank you.

Servers by jDrones