Telemetry problems

Trying to get Cube Black, crossfire nano and yaapu to work with no luck. Can get radio channels to work fine, but Yaapu doesnt work It doesnt say no telemetry but moving the cube around doesn’t display HUD movement or any other meaningful parameter. I’m in Telem1 on the pixhawk and have the rx wired with 4 data wires. TX is set, in order, as crsf tx, crsf rx mavl rx, mavl tx. Ardupilot telem1 post is set at 115200 and protocol 23.
In the TX crossfire setup I get an Ardurover V4.1.0 device, in that all items say FormatVersion 16, whatever that means or is supposed to say I don’t know. Looking at raw telemetry parameters in TX16S all the relevant sensors are there and they alter on moving cube around.
Any ideas? I’ve also tried what TBS say with SR1 but still no joy getting anything in Yaapu.

Disconnect mavl - you only need CRSF. Do you have RC_OPTIONS set to +256?

Was on 288 - changed to 256 still doesn’t work. Deleted all sensors and re-discovered them, still no joy. Removed the other two wires and set rx to crsf tx, crsf rx ch3, ch4.

If you get the ArduRover device listed then stuff is basically working. Do you have the latest yaapu widget installed? Do you have CRSF enabled in it?

Yea latest Yaapu where do you enable CRSF in it?

SYS->yaapu config->enable CRSF telemetry

Andy - Found Yaapu Telemetry widget but there’s no option in the 30 options in there to set CRSF? Only enable ones are Haptic and px4 flightmodes? Telemetry widget is 1.8.1 - is that the right version?

Nope - you need something like 1.9.5

Yea - downloaded and overwrote but still showing as 1.8.1? Must be something screwy on my SD card somewhere.

Was indeed my SD card. Become corrupt and a replacement fixed it. Thanks for your help Andy.