Telemetry over S.Port suddenly stopped working


a few days ago I tried to setup Yaapu telemetry on my Jumper T16 with an FrSky S6R receiver. It initially worked, I tested it quite often during the setup and it always worked. Until it didn’t. I’m not sure when exactly it stopped working but I think after a reboot of the flight controller by disconnecting the battery (since there was a compass invariance warning since the battery wasn’t in the right place). Before it worked all the time, I mostly used USB-power while setting it up.

I’m using a Cube Orange, the connection is on GPS2 (UART4/SERIAL4) with Protocol 10 and Serial_Options 7. I also tried it with another output (Telem2/Serial2), it still doesn’t work and I also tried attaching a telemetry radio to the GPS2 port, this also works. The connection to the receiver is a simple cable to the S.Port pin and a 10k resistor from the signal line to ground.

Is there anything I’m missing or did I just fry the receiver? The receiver is working fine (apart from S.Port), the control surfaces move according to my control input. Thank you!

Rx is pribably fine, was it a parameter change around the serial setting etc that only took effect on the reboot, whenever i get something working i like to save the parameters incase i stuff it up in future so i can revert back to a known configuration, kinda like a windows backup…