Telemetry on X20s showing nothing but gps

Hello there,
I have setup telemetry from my pixhawk to my R8PRO and tried to get telemetry to work. I tried setting the mode of the Serial 2 Port to 4 and 10. I think, as I am not running a LUA script, I should be using the 4 option, but anyway, I still just get the GPS coordinates. Is there any option to configure what is transmitted? Or is this an issue with my configuration?

Thanks for any advice!!

The X20s would need to be able to run the yaapu telemetry script to get more than just GPS, and it can’t. Whole new operating system, not OpenTX.
Frsky sensors will give you some more data, like voltage and current, but it’s not much.

It’s an issue with unsupported features in the Silo firmware Ethos. Give it time, I suppose that will change.

OpenTx, not.

I am one of the X20 beta testers.

We need to wait for LUA scripting support to be added to the ETHOS firmware and for the Yaapu scripts to be updated.

FWIW, I also have a 250 racer with an F4 fight controller running BetaFlight. I am using an R9 MX receiver. My X20 detects multiple sensors.

Actually I am very happy with the radio and the software. But I don’t have a good radio background, only used a Futaba T8j until now.
My main experience is with programming and using foh mixing consoles, and this worked out to making ETHOS pretty intuitive, so for me, it’s quite good.

Thanks for your advice, so I will need to wait for the LUA script support…

Thanks, thats interresting. I am actually very happy with the hardware and software till now. Just not sure how to couple together my R9MX and R8PRO.
Can’t wait to go flying with it.

You can ask questions here:–-FrSky-X20-X20S-X20HD-Tandem-and-ETHOS

I have both of those receivers but are in two different aircraft.