Telemetry not connecting in mission planner

**hi Friends,
I have a new PIX4 which I am setting up on my hex. Some how when I try add my 3DR telemetry
between my pix and mission planner, I am not getting connection over 57600 port.
I reinstalled the Silicon labs driver and still cannot connect over COM3 and 57600 with my ground station.
But when I tried to connect with my RPI and MAVLINK I can connect the UDP and 957000 to MP.
I tried a different groundstation telemetry that I bought on amazon and its the same result.
Once in a while some how there is connection but without any param update in MP and I lose connection again.
The lights in ground station and pix both blink green. Some times they blink red/green.

Do I need to do an config chnages in MP for my groundstation to talk with my pix with my 3dr?
Thank you
Walt
**

1 Like

Good day, did you check the correct pinout of the telemetry with your flight controller?

1 Like

If the light is blinking green then the radios are not connected or paired. You will need to sort that out before continuing. The lights will be solid green once connected.

https://ardupilot.org/plane/docs/common-sik-telemetry-radio.html#status-leds

yes, only difference that my radios dont have CTS and RTC pins.
image

Hi, I have solid green light on both radios. And even able to download settings in remote radio without connecting it to computer.

If you can get to the that point, the radios are connected. That’s good.

Now I would double check that you have the serial port settings on your controller set correctly.

Havent done any serial port settings. What should I do?

What controller do you have? What port are you connected to?

Where do I look for controller. I just bought a new FPV telemetry and connected to telem2.
But still with com3 and 57600 it times out.

What parameters do you have in Ardupilot?
Are the two telemetry radios showing as linked? Usually a solid green LED for a good link, flashing for a bad link.

No the telemetry is not linked. Thr ground module is showing blinking green and air module doesnt have any light.
This is the 3rd one I am trying.

I just set the serial2_baud to 57 and serial1_baud to 115.
Now I have air and ground modules in blinking green. But no connections.

You’ll need to connect each directly to MissionPlanner (like the ground module normally is) and use the sik radio screen to make sure they have all the same settings

https://ardupilot.org/copter/docs/common-configuring-a-telemetry-radio-using-mission-planner.html

A lot of flight controllers dont support powering a telemetry radio from a serial port, and you may need to supply 5vdc from a BEC.

If you’ve got cheap radios that are pretending to be “500mw” or some figure very different to the original 3DR telemetry radio, then there is a good chance it will never work properly.

I have holybro durandal and tried every port telem 1 to telem 4

On the Durandal telemetry 1 is serial1. Check the link below for the serial mapping of the other ports.

Check the serial ports is set up:
SERIALx_PROTOCOL,1
SERIALx_BAUD,57

If you have solid green lights the radios are connected to each other. The issue then is between the radio and your computer or the radio and your controller.

When you connect Mission Planner make sure you select a baud rate of 57600.

Telemetry is working! Big thanks for your help!:slightly_smiling_face:

1 Like