Servers by jDrones

Telemetry issue using yaapu cable on pixhawk & taranis q X7

Hello Community,

I am facing issues trying to get telemetry to work. My configuration:

  • Quadcopter: Tarot 650
  • Flight Controller: Pixhawk 2.4.8
  • Receiver: Taranis RX8R
  • Transmitter: Taranis Q X7 with Open TX 2.2
  • Telemetry cable: Aliexpress yaapu telemetry cable connected between SERIAL 4/5 on the PIXHAWK to the Smart Port on the receiver. Note that I set the SERIAL4_PROTOCOL to 10.

When I “discover new sensors”, I get only 3 sensors: RSSI, RxBt and GPS. I would like to get all the availbale sensors including battery voltage.

Could you help me please?

Thank you!

the telemetry scrips doesn’t use sensors, you have to install the scrips on the transmitter. see:

1 Like

Hello Peter and thank you for your quick reply.
Sorry I should not have said « sensors », I understand that this script does not use sensor and collect all the data from the flight controller.
I have connected the pixhawk to the smart port of my rx8r using a specific cable bought on AliExpress. Once connected and setup (on both taranis and pixhawk), the only data I manage to read is the GPS one (the position). I do not get any other value.
Regards

Did you try Telem2 and SERIAL2 instead?

Good luck

https://discuss.ardupilot.org/uploads/default/original/2X/f/f04056f6da35b6ef935e7143c5abb7a7e3338254.jpg

use the one from the photo above that will work
Are you using which serial port?
have to open the app by the page of telimetry on the radio can not open directly through the file

Thx rollys for your support.
I have just tried Tele2 and Serial 2 in Mission Planner and I loose the GPS, only RSSI & BtRx remains.

Hello manotroll,
I have bought this one on Aliexpress, see pictures.

image1 IMG_6395

I am using Serial4/5, with SERIAL4_PROTOCOL set to 10 in Mission Planner.

Where did you get yours from?

Thx

I built mine like the picture above.
I’m using telemetry 2
just define
SERIAL_BAUD 57
SERIAL_PROTOCOL 10
remembering that in no other port can have some defined telimetry parameter

I was able to open the script on the radio?

I have no personal experience with your type of cable since I use the Craft and Theory and works well for me. I use it for both ArduPlane and PX4 firmware. If I didn’t know any better I’d say it might be an issue with the cable.

Good luck.

Thanks @manotroll and @rollys
I will try to get a converter and try to build my own cable.
I will tell you if it works!
Best Regards,

right on the radio is written what when you open the script?

You do have the Yaapu telemetry script installed correct? also, when you installed openTX firmware did you add the LUA script option?

I’ve seen this before. Until you have the LUA scripts installed the radio will only discover RSSI, RxBt, and GPS.

You need to read the Yaapu Telemetry Wiki and make sure you have the files copied to the correct directories on the radio SD card.

Then you need to make the first telemetry screen use the appropriate yappu script, either yappu7.lua or yappu7. luac .

Servers by jDrones