Telemetry issue Getting Params ...(sysid 1 compid 1)

Hi guys , this is my first post asking for your help please !
I was trying to use a 3RD telemetry clone on my arducopter module (APM 2.6). It is all set-up via USB cable .
Once hooked up via telemetry mode after connecting ( checking twice the com port and the baud rate ) a message pops up saying " Getting Params …(sysid 1 compid 1)" .-
I tried everything I read ( reset to default, downgrade the firmware etc…) nothing worked .
The weird thing is that moving the board the horizon line follows its movements and the copter icon seats just in the right spot on the map pointing the right way ?!?!?
Any suggestion from the expert

I am dredging old memories up here of having this issue.
You haven’t said but but Mission Planner on Windoze, right?

I am pretty sure that where the issue lies.
Either com port problem, typical Windoze, or Mission Planner reinstall.

I still have some APM 2.6 and they work fine.
Just checked with the latest stable Mission Planner on Win7 and connects fine to an APM2.6 running 3.2.1

Thank you Mike .
It’s MP on windows.
I’ll try to reinstall and I’ll let you know .
The weird thing telemetry system was working for the very first time and than it stopped.
Mystery of the binary ?!?!?!:roll_eyes::upside_down_face:

I’m stuck here !!
These are the message I got on connecting my board.