Servers by jDrones

TELEMETRY CONNECTION - 915mhz 3dr radio

I am trying to connect the Telemetry between my computer and car, when I plug in the 2 radios (1 to the car and 1 to the computer) the green lights just blink, i read that it is suppose to turn solid, so when i go to mission planner and try and do the configuration , it only recognizes the local side and not the remote

Does anyone know what I can possibly do to solve this ?
thank you for any help

  1. Connect the ground station USB cable to the first radio and write down the radio settings.
  2. Connect the ground station USB cable to the second radio and adjust the settings to match those of the first radio.
  3. Connect everything back, now the mission planner configuration tool should see both radios.
1 Like

The second radio does not have a usb cable , it just have the part to plug into the telemetry 1 port

https://ardupilot.org/copter/docs/common-serial-passthrough.html

1 Like

so I got them to read each other finally but when I go to connect them together, it still says no heartbeats received , you know why that may be ? or what I can possibly do next ?IMG_7527

Update mission Planner. What Ardupilot Hardware and Firmware are you using?

I have version 1.3.74 of mission planner and I’m using ardurover on pixhawk 2.4.8

is there a more up to date version that than ? when I click the check for updates button on mission planner , it say there are not any and I am not sure what a beta update is

Servers by jDrones