Servers by jDrones

Telemetry - can't load settings - fails to enter command mode

I am trying to set up a pair of telemetry radios using Mission Planner 1.3.56. I have a Pixhawk 2.4.8 flight controller. The “flight” radio shows a solid green LED and a flickering red LED. The ground station radio shows a solid green. I interpret this to mean the radios have found each other and that the flight radio is sending information. I would like to load the radio settings into Mission Planner. Forgive the following - I am new to this.
According to the on-line instructions, I have confirmed that the ground station is associated with the correct COM port and its baud rate is set to 57600 (Windows Device Manager confirms this). Following the instructions to not connect, I click on the “Load Settings” tab which should download the settings and populate the screen with information. Instead the request times out and I get a pop up message that informs me “Failed to enter command mode” . One more piece of information, the com port and baudrate are indicated in the upper right hand corner of the screen, below it is another drop down text box that has nothing shown in it. If I connect the ground station to the pixhawk with a USB cable this box does show me the com port associated with the USB cable. I think this is significant information! The USB cable is not in place when I attempt to set-up the radios - I believe that this is the correct thing to do.

Looking forward to hearing what I’m doing wrong!

1 Like

Hello, any updates on your issue? I’m having a similar problem.

Thank you.

I was getting this error and to fix it, I connected one radio via the PX4 ->USB to one comm port on my computer and then plugged the ground into another comm port on my computer (the instructions say to just connect the one). I connected to the ground radio comm port (Silicon Labs) I don’t know if the radios are healthy yet but at least I was able to load settings in Mission Planner.

I was getting this error as well, and it turned out to be my baud rate settings in the Windows com port which can be accessed through Device Manager under the ‘Ports’ section. The com port number and the baud rate in Mission Planner must be set to the radios’ currently set baud rate as well. These are located at the top right of Mission Planner. If you don’t know the currently set baud rates of the radios, then you may have to try each baud rate one by one to find the right rate. Hope this helps!

Servers by jDrones