Tarot gimbal behaving erratically


I have an issue controlling the tilt angle of my tarot gimbal with APM 2.5. I can control the gimbal perfectly with a servo tester, but connected to any APM auxillary output, the gimbal is moving erratically. In the tarot configuration software I can see the tilt rc value jumping when I turn the knob on the transmitter. I tried A9-11 and even RC5-8 on the output rail.

The strange thing is, when I connect the gimbal to one of the ESC outputs (RC1-4 on the output rail), voila, I can control the tilt angle with the throttle stick, but on all the other outputs the behaviour is uncontrollable. Unfortunatly, i cannot connect the gimbal directly to my RC receiver, because i’m using the PPM signal of a JETI satellite receiver (RSAT2).

Any idea…?

APM 2.5
Tarot Gimbal Firmware V1.5
Mission Planer 1.3.7
ArduCopter V3.1.5

Best Regards,

Solved it…

I simply had to re-calibrate my RC. When I calibrated it during the initial setup, the tilt channel was not assigned to a knob on the transmitter yet, so I didn’t calibrate it. Apparently the mix/max values for that channel got saved anyway, and when I started to turn the knob the values were way beyond the limits. I think this is what caused APM to generate the jumping output values.

So, when you start to put another RC channel in use, re-calibrate!


Hi Claus,

Thank you for the update!

For others reading this post here is the link to the tarot wiki information: