Tarot 650 sport set-up problem(copter 3.3 rc 12)Beta mp

This is a new quadrocopter. Pixhawk auto pilot,sbus out.taranis radio,X8r receiver,Xrotor 40 amp opto esc’s,Tarot 620kv motors,4 cell lipo.

Here is the issue: Throttle in stabalize all motors spool up normal.
If I switch to alt-hold ,loiter,pos hold the throttle spools up,but when I reduce the throttle it seems to take a long time to spool down.Also, when armed the motors start to turn.Even if I set min throttle from 130 to 0,they still turn when armed. Anybody have suggestions?

By default, the software is set up to slowly spin the rotors when armed. This is (was?) controlled by the MOT_SPIN_ARMED parameter. If it’s 1, then the motors spin. If it’s 0, then they won’t spin when armed. You can find mention of it on this wiki page in the Overview section:


But I’m a little puzzled since I don’t see that parameter listed in Arducopter’s current full parameter listing. Perhaps someone can chime in as to if this parameter has been removed in the latest version?

Thanks for the reply.That makes sense now. :smiley:

I needed to re-calibrate X-rotor 40 amp opto esc’s(throttle cal).
Everything works FANTASTIC! Excellent flying characteristics in all modes.Have not tried auto mode yet.
I’m just using stocks PID’s and is very very stable. Controls are very crisp and precise… :smiley:

This is considered solved!! :slight_smile: